[4.2] - TODAY keyword doesn't do anything in a View - Forum - Rollbase - Progress Community

[4.2] - TODAY keyword doesn't do anything in a View

 Forum

[4.2] - TODAY keyword doesn't do anything in a View

This question is not answered

Hello,

I was trying to configure a filter for a view and am using the "TODAY" keyword. However, this keyword doesn't seem to work and is not displaying any results. Is this a known bug?

Cheers.

Iram

All Replies
  • Any luck with finding this bug?

    Iram

  • Configuring it like this, the TODAY keyword works. Could you specify your exact usecase (condition, field type, etc)?

  • Hello ,

    I have a date/time field and I am checking whether the date/time is greater than or equal to TODAY's date and its throwing an error in the console.

    Error postProcessJson: SyntaxError: Unexpected identifier

     



  • Hi Iram,

    I have tried with Date and Date/Time fields and could successfully filter the records based on TODAY keyword.

    Could you let us know on which build of Rollbase you are trying this?

    If its not the latest build, would like you to try on the latest build and share the results.

    Thanks,

    Shivani.

  • Hi Iramk,

    I tried the scenario in 4.2.2.2 build , but couldn't reproduce it.Could you please share the app xml?

    Thanks,

    stayal

  • The version that I am on is V4.2.0.0. as mentioned in the subject. Its not working in the latest build either, I am getting the exact same processJSON error.

  • Hi IramK,

    Can you please share your app xml , it would be helpful to reproduce the issue?

    Regards,

    stayal

  • Hello ,

    This is happening for us across the board even for reports and not just views. I'll see if I can get you a test application xml, or if it would be easier to do a screenshare session? Let me know which is better and quicker please.

    Cheers.

    Iram

  • Hello ,

    I found out that the issue only occurs on a date field and not a date/time field. It's as though date/time fields work properly with the TODAY keyword where as the date only fields don't.

    I have attached the XML to test.

    Cheers.

    Iram

    Test Application_v2.xml

  • Hi,

    Has this been fixed?

    We're on 4.5.2.0 and the TODAY keyword doesn't seem to work on view filters.

    cheers.

  • Hi,

    TODAY keyword is working fine on View filters.

    Could you share you exact filter condition?

    Thanks,

    Shivani.

  • Hi,

    I tried a dateField less than TODAY filter and it doesn't work for date fields (work for date/time fields).

    I had to use a formula dateField < NOW() and it works fine.

    cheers,

    H

  • Hi,

    Could you share a sample test app to reproduce this issue?

    Thanks,

    Shivani.

  • I have experienced this.

    Steps:

    1. Create a DATE field.

    2. Create a view and use the new date field as a view filter (don't use the built-in date filter but create your own).

    3. Left hand side == Date, Operand == Equal, Right hand side (value) == TODAY

    4. Populate records with today's date.

    Result: No records found in view.

    Workaround:

    I had to use two filters to get this to work for Date fields.

    1. Date GREATER than TODAY-1

    2. Date LESS than TODAY+1

    That is the only way apart from using the built-in Date filter.

  • Hi,

    I have tried the exact case on 4.5.3 version and could not reproduce it. If you are on V 4.5.2, I would suggest to try it on the V4.5.3 or on the EAP environment.

    Also, I have attached the sample application that I used for testing. If you still see the issue, you could raise a Support ticket for the same, so we could gather more information.

     TestDate1_v2.xml

    Thanks,

    Shivani