Why the "External Database" is disabled? - Forum - Rollbase - Progress Community

Why the "External Database" is disabled?

 Forum

Why the "External Database" is disabled?

This question is answered

Hi,

I'm trying to add a new "Object from an External Metadata" however the "External Database" option is disabled?

Is there any way to find out why?

I got two databases configured - one set as external and the other one set as non-external (Master database). Both have a status of "Running".

Thanks for any help!

Marcin.

Verified Answer
  • Hi -

    The Database you set as external should be the default database for the tenant from which you are trying to create external objects. This can be set only during customer creation time and cannot be changed later on.

    If you trying this on the master tenant, then changing the master tenant's db to external and restarting the system should ideally work.

    If this does not help, please provide us details about your configuration.

    -Thanks,

    Manooj

All Replies
  • Hi,

    I just want to confirm.

    Have you restarted the Rollbase after the modification?

    Thanks and Regards,

    Chandra.G

  • Hi -

    Please check if the DB marked as external is the db set as default.

    -Regards,

    Manooj

  • Yes, it's been restarted after adding the database. Then it has been restarted again to make sure.

  • Setting the external db as default does not make any difference - still got the "External Database" disabled.

  • Hi -

    The Database you set as external should be the default database for the tenant from which you are trying to create external objects. This can be set only during customer creation time and cannot be changed later on.

    If you trying this on the master tenant, then changing the master tenant's db to external and restarting the system should ideally work.

    If this does not help, please provide us details about your configuration.

    -Thanks,

    Manooj

  • Thanks Manooj, this makes sense to me. Having the customer assigned to the external database made the "External Database" options enabled.

  • It may be a good idea to have explanatory message instead of just disable option.