PDF attachments Loading Issues - Forum - Rollbase - Progress Community

PDF attachments Loading Issues


PDF attachments Loading Issues

  • Dear GURUS

    I have a small issue with the PDF files.

    some of the users when they try opening the attached PDF file we get the error and after sometime if you click the same PDF document it opens without any issues. 

    First time the error it throws is  " System Error - You do not have permission to access this record"  but we just wait for 2-3 minutes and click the same link it  opens like a charm... 

    Any help plz

  • Hi Kayala,

    Can you provide the following information on your problem?

    1. How are the PDF files accessed? It could be:
    > an attachment from an email sent by Rollbase.
    > a link from an email sent by Rollbase.
    > a link from the Rollbase application.
    2. What user role did they use when the error was displayed?
    3. What actions did they do (e.g. refreshing the page, logging in another user from the same browser, etc.) while waiting for 2-3 minutes?

    Also, if you want the file to be publicly accessible, please check 'Make files publicly accessible (do not require login)' from the field definition of your file upload field.

  • Dear Godfrey

    Well that sounds really silly.. but that's the fact.

    I'm trying to replicate the same issue by assigning the same rights as the person facing issues to the test user but it works fine.

    If I'm tying to do the same with the user having issues its giving such a vague issues like saying no permission to view the attachment.

    I can read the announcement properly but only thing is not able to click open the PDF document. for UW manager

  • It's a good option if the link to the files are only sent via Email. Non-authenticated users can only view the file when they have the link.

    Anyway, can you get a screenshot of the error and URL from the user who's experiencing this issue?
  • Well this is the link it shows.



    I also tried assigning the user role as the who is getting the issue, but unfortunately the test user is not getting the same issue at all 

    The normal link to that PDF file is 


    which is what I'm able to view with the test user we have assigned the same User Role as the one who is facing that issue

  • Your file upload field is configured to be publicly available - I was able to access it without logging in. Was this this configured recently?

    Based from the URL, the link to the file is parsed from {!file#html} token. I can only reproduce the issue on non-public file upload fields when:

    1. My default browser is not logged in to Rollbase.
    2. The user account I am using does not have view permissions to the object.
  • Dear Godfrey

    Thanks for your reply

    Well you can cut the first option out, as I've tried with couple of temporary users in the same browser it works fine.

    Also I've tried all the possible options in the system, but unfortunately its working for some users of the same group and for some it throws the system error.

    Normally what type of permissions should be available for this type of attachments.

    My question is : If users are able to see the post why is it throwing error only on the attachment....

  • If the attachment belongs to the 'post' object, then the only logical reason behind the error is the field permission of the file upload.

    Kindly provide me your customer ID so I can also check your logs.
  • Hi Kayala,

    Does your customer still get this error?