OpenEdge 11.6 - After a power outage, our Test server shows all DB's "Offline" - Forum - OpenEdge RDBMS - Progress Community

OpenEdge 11.6 - After a power outage, our Test server shows all DB's "Offline"

 Forum

OpenEdge 11.6 - After a power outage, our Test server shows all DB's "Offline"

This question is not answered

Hello all,

New OE user here, with no training (yet).  

OEE shows all our DB's as "Offline" after the server was shutdown due to a power outage last Saturday, 8/4/2018.  The last entries in the DB .lg files show this:

[2018/08/04@06:41:39.729-0400] P-2136 T-4432 I SRV 5: (794) Usernum 165 terminated abnormally.
[2018/08/04@06:41:39.729-0400] P-2136 T-4432 I SRV 5: (739) Logout usernum 165, userid bruceg, on SRV-MA-EFI-TEST.
[2018/08/04@06:41:39.734-0400] P-2136 T-4432 I SRV 5: (794) Usernum 174 terminated abnormally.
[2018/08/04@06:41:39.734-0400] P-2136 T-4432 I SRV 5: (739) Logout usernum 174, userid bruceg, on SRV-MA-EFI-TEST.
[2018/08/04@06:41:42.120-0400] P-9184 T-6208 I SRV 20: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.120-0400] P-15400 T-5320 I SRV 19: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.121-0400] P-15696 T-1728 I SRV 15: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.121-0400] P-12748 T-16936 I SRV 16: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.121-0400] P-6352 T-14300 I SRV 18: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.121-0400] P-16336 T-16340 I SRV 17: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.121-0400] P-12036 T-8780 I SRV 14: (9438) CTRL_SHUTDOWN_EVENT console event received.
[2018/08/04@06:41:42.123-0400] P-3744 T-15380 I BIW 21: (2520) Stopped.
[2018/08/04@06:41:42.123-0400] P-3744 T-15380 I : (453) Logout by SYSTEM on batch.
[2018/08/04@06:41:42.137-0400] P-2136 T-4432 I SRV 5: (2520) Stopped.
[2018/08/04@06:41:42.145-0400] P-12132 T-4240 I SRV 7: (2520) Stopped.
[2018/08/04@06:41:42.163-0400] P-12036 T-11584 I SRV 14: (2520) Stopped.
[2018/08/04@06:41:42.163-0400] P-6352 T-11820 I SRV 18: (2520) Stopped.
[2018/08/04@06:41:42.188-0400] P-14900 T-8576 I APW 23: (453) Logout by SYSTEM on batch.
[2018/08/04@06:41:42.201-0400] P-17220 T-16420 I OEMAGEN24: (453) Logout by DB_Agent on batch.
[2018/08/04@06:41:42.206-0400] P-12748 T-4856 I SRV 16: (2520) Stopped.
[2018/08/04@06:41:42.270-0400] P-16336 T-300 I SRV 17: (2520) Stopped.
[2018/08/04@06:41:42.282-0400] P-15400 T-10848 I SRV 19: (2520) Stopped.
[2018/08/04@06:41:42.298-0400] P-9184 T-14104 I SRV 20: (2520) Stopped.
[2018/08/04@06:41:42.302-0400] P-15696 T-17280 I SRV 15: (2520) Stopped.
[2018/08/04@06:41:42.306-0400] P-17044 T-17400 I BROKER 1: (453) Logout by SYSTEM on batch.
[2018/08/04@06:41:43.327-0400] P-11372 T-14528 I BROKER 0: (15192) The database will complete shutdown within approximately 60 seconds.
[2018/08/04@06:41:43.328-0400] P-11372 T-14528 I BROKER 0: (2249) Begin ABNORMAL shutdown code 2
[2018/08/04@06:41:44.326-0400] P-11372 T-14528 I BROKER 0: (5179) Registry error 1717: Could not register 'VISION_PROGRESS' events with the Event Viewer.
[2018/08/04@06:41:44.326-0400] P-11372 T-14528 I BROKER 0: (2263) Resending shutdown request to 1 user(s).
[2018/08/04@06:41:45.048-0400] P-8524 T-17000 I WDOG 22: (453) Logout by SYSTEM on batch.
[2018/08/04@06:41:45.048-0400] P-8524 T-17000 I WDOG 22: (5179) Registry error 1717: Could not register 'VISION_PROGRESS' events with the Event Viewer.
[2018/08/04@06:41:45.329-0400] P-11372 T-14528 I BROKER 0: (5179) Registry error 1717: Could not register 'VISION_PROGRESS' events with the Event Viewer.
[2018/08/04@06:41:45.329-0400] P-11372 T-14528 I BROKER 0: (453) Logout by SYSTEM on batch.
[2018/08/04@06:41:46.363-0400] P-11372 T-14528 I BROKER : (5179) Registry error 1717: Could not register 'VISION_PROGRESS' events with the Event Viewer.
[2018/08/04@06:41:46.363-0400] P-11372 T-14528 I BROKER : (16869) Removed shared memory with segment_id: 43122688
[2018/08/04@06:41:46.363-0400] P-11372 T-14528 I BROKER : (5179) Registry error 1717: Could not register 'VISION_PROGRESS' events with the Event Viewer.
[2018/08/04@06:41:46.363-0400] P-11372 T-14528 I BROKER : (334) Multi-user session end.

 

All of the DB's in the Data folder are there, it's like OE lost a configuration file somewhere.  I restored a backup of the %DLC%\Properties folder as a hunch, since that seemed to have a lot of the OEE configuration, but that didn't seem to help.

I can probably manually add these back to OEE as I have some experience doing that, but I'm more interested in finding out where/what got hosed.  

When I try to start the DB, here is what I get:

 

C:\Data\Pilot>dbman -start vision
OpenEdge Release 11.6.3.029 as of Thu Aug 31 10:55:28 EDT 2017

ERROR: Unable to locate database vision (DBMan005)

C:\Data\Pilot>proshut vision
OpenEdge Release 11.6.3.029 as of Thu Aug 31 10:55:28 EDT 2017
There is no server for database vision. (1423)

C:\Data\Pilot>

However, in that folder there are plenty of .db files as well as the .st file for the DB.  

 

Can anyone offer any help with this, or where else are good location for log files that might indicate what happened?

 

All Replies
  • look at syntax for dbman command.  dbman -database vision -start

  • You better check the conmgr.properties file and see if the configuration on vision is there or not if not then you can use the proserve command to start the database