Importing data and date issues - Forum - OpenEdge RDBMS - Progress Community

Importing data and date issues

 Forum

Importing data and date issues

  • I am currently importing my Progress database into Oracle, and in doing this I have some data in .d-files that I need to import into the Oracle database. I am connecting to the Oracle database through Oracle DataServer which works fine.

    The issue is that the .d-files have dateformat specified as dmy-1950, but the import into the database is in dmy-1976 as the warning from the import tells me. This can be problematic when it comes to converting two-digit years in date correct.

    How can I force the import of .d-files ot use dmy-1950? I can not use the "-d dmy -yy 1950" on the Oracle database, and I can not see how this can be forced.

    I am using the Data Administration tool.

    Any ideas?

    Message was edited by:

    Stein Rune Risa

  • Redo the export with the correct cutoff.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • The cutoff used when exporting is "correct", so I'd rather not changed that. The real problem is how to change the cutoff when importing...

  • No cutoff is more or less correct than any other. It is simply a question of convenience at time of data entry. If you exported with a cutoff of 1900, then every date would be 4 digit year ... as long as Oracle reads it correctly, it turns into a date and then you can set the cutoff for UI whatever you want.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • How can I force the import of .d-files ot use

    dmy-1950? I can not use the "-d dmy -yy 1950" on the

    Oracle database, and I can not see how this can be

    forced.

    Why can't you specify the "-yy 1950" on the commandline when you start the "data administration" tool? Another workaround would be to start the "editor" via the "tools" menu in the data administration and set the year programmatically:

    SESSION:YEAR-OFFSET = 1950.

  • Yes, I found the SESSION:YEAR-OFFSET = 1950. solution, and tried that with success.

    Regards to setting the -yy for the data administration tool: I thought this was done only on the databases? Is it possible to set it for the session on the command line as well? Something like prowin32 -yy 1950?

  • Regards to setting the -yy for the data

    administration tool: I thought this was done only on

    the databases? Is it possible to set it for the

    session on the command line as well? Something like

    prowin32 -yy 1950?

    It's a client parameter so it works like that. You might want to check if your shortcut already uses a "-pf " option where this -yy has been pre-defined. I find it funny that your session value is 1976...