nasty looking error - Forum - OpenEdge RDBMS - Progress Community
 Forum

nasty looking error

  • Just tried adding a delta.df to my database. Got this error:

    SYSTEM ERROR: bfdiscon: rmrep failed. Dbkey <record-number> for <table>, error <error-number> (23) (11206)

    An unexpected system error occurred while attempting to write an updated data record <record-number> for table <table> to the database. 

    This was a 10-11 converted database (several weeks ago)

    windows 7, enterprise DB v11.0

    See pretty screenshots

    db error.PNG

    db error2.PNG

  • meh. tried index rebuild. tried truncating bi.

    looks like dump & load next option

    Unless someone can help me out ..

  • Unless someone can help me out ..

    ETSC?

  • interesting.

    split the .df into two parts.

    Loaded part 1. no problems.

    Loaded part 2. no problems.

    go figure.

    Now, is there anything that I should be checking to see if the db is still borked in some way.

    I still have a copy of the db that had the problem originally, as well as the df file that caused the problem if anyone is still interested in the cause.

  • heh. was hoping that I would have something concrete to tell them. At least I have a workaround for now.

  • TS is generally interested in reproducible bugs...

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com