Default Port Numbers - Forum - OpenEdge RDBMS - Progress Community
 Forum

Default Port Numbers

This question is not answered

Is there a comprehensive list of default port numbers used by a modern version of OE?  I have looked through the 11.6 e-docs and see partial tables.  The Kbase seems to have snippets as well.  Ideally, I am looking for the service and the default ports used by the installer.

The use case is getting a few version of OE running on the same computer.  Each version will run independently including WSA, AppServer, TomCat, DB Servers, Fathom  etc.  using multiple OE11 versions and most likely at 10.2B in there for good measure.

I want to document my setup and have reasonable choices for all of the conflicting default ports.  I know I can dig it all up myself - just seeing if I can tag along on work that has already been completed.

Bob

All Replies
  • A KB on "adminserver default port" will return a list of helpful articles.

  • Thanks Tim.  I had already done that search and found a few partial lists.  I seem to recall seeing the list I seek somewhere in the past.  Just can’t seem to recall where or when.  Conflict at the Adminserver level for multiple versions of OE on a single machine and then the defaults used by each for the various components is the crux of it.
     
    Bob Brennan
    Integrated Manufacturing Systems, Inc.
    (603) 424-0109
     
  • if you're looking for a list of -adminport - this is the KB
    000010425

    The port referenced by the -adminport parameter, is the communication port between the servergroup and the AdminServer, used by databases to communicate with the AdminServer.  The -adminport parameter may be changed in Service Packs (SP) as well as in new major commercial releases.  

    The following is a list of default values for this parameter dependant upon the version of Progress OpenEdge being used:

    Default      Progress OpenEdge version
    -adminport

    ------------.-------------------------------------------------------------------------
    7835         any Progress 9 version below 9.1E, OpenEdge 10 and 10.0B SP01 (included)
    7836         Progress 9.1E01+
    7837         OpenEdge 10.0B02+
    7838         OpenEdge 10.1A
    7839         OpenEdge 10.1B
    7840         OpenEdge 10.1C
    7841         OpenEdge 10.2A
    7842         OpenEdge 10.2B
    7842         OpenEdge 11.0 to 11.1 inclusive
    7843         OpenEdge 11.2 to 11.5 inclusive
    7845         OpenEdge 11.6



    The port referenced by the -port parameter, is the main AdminServer listening port, where all queries, and start/stop requests are sent for example when running: proapsv -query -port <port>

    The default listening port for the AdminServer (-port) remains 20931for all versions.

    To configure different -adminport -port parameters:

    For OpenEdge 10.1B and later, refer to Article P159835, How To Configure Multiple Versions of AdminServer To Be Run Concurrently since OpenEdge 10.1B   which includes additional unique ports to be considered for the OpenEdge Console (OEM/OEE).
    For OpenEdge 10.1A and prior, refer to Article P10465, How to configure multiple AdminServer versions to be run concurrently on Windows