Error message nr 1432 when connecting Client to MS Sql database - Forum - OpenEdge RDBMS - Progress Community

Error message nr 1432 when connecting Client to MS Sql database

 Forum

Error message nr 1432 when connecting Client to MS Sql database

  • Hi,

     I try to connect my client application (Progress 9.1E)  to an MS Sql database (SQL2014)  running on a Windows server 2012 R2.

    The product SQL Server 7 Enterprise is installed on the server. One  ODBC Data source is configured on the server,  and the Progress Dataserver Broker is also operational and started on the server.

    When I start The Progress Data Administration on the Server, I can connect the SQL Database successfully.

     But when I try to  connect from the client to the SQL database (via the schema holder) , I got the message nr 1432: "Could not connect to server for database <DataSourceName>, error=0". 

    I don't find additional information about this message in a log file or in the Event viewer on the Client PC.

     I have the same configuration to access another MS Sql database  (SQL2008) running on a Windows server 2008 and in this case all is fully operational.

    If somebody can help me  with this message 1432, I will be very grateful to him

     Thanks

  • Hi Galloy,

    Progress 9.1E is not certified with MS SQL 2014.

    MS SQL Server 2000 is the most recent release being certified against Progress 9.1E.

  • Hi,
    I have found a kabse which might helpful for this case.
     
    Thanks
     
  • Hi,

    Thank you for your help.

    My problem is almost solved.

    It's a problem with the firewall on the server.

    If I turn off the firewall, all is working.

    Have anybody  an idea of the PORT(s) that must be opened on the firewall ?

    Thanks