Error - The server or system has no more resources , when start appserver - Forum - OpenEdge RDBMS - Progress Community

Error - The server or system has no more resources , when start appserver

 Forum

Error - The server or system has no more resources , when start appserver

  • We need help on this problem, hopefully somebody experience this can help.

    We encounter this problem after restoring the db with backup and enable ai.

    FYI, we have 2 databases in our server , 4G , 2 processor of Core Duo .

    Previously was running fine but after restoring db and enable AI , the appserver can only start up 12 appserver for 1st database , more than that will kill all the appserver and cause the appserver stop functioning.

    Strangely, I check in the Server , the RAM are still have 2G not used , which does not seems like we are running of resources.

    Even more strange, we stop the 20 Appserver for the 2nd database (hope that will free resources) and start up the 15 appserver for the 1st database, the problem still there.

    It seems like this problem is particular to the appserver for 1st database , the appserver of 2nd database is startup or not (initial server=20)

    Thanks in advance for any help or hints .

  • I can't speak directly to your problem, but in your spot one of the first things I would do is to reboot the whole system in case some resource has not been released.

    To get the best help, you should cite your Progress version, the type and version of your OS, and you should quote any errors which you can find in the logs.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Thanks for the reply.

    Sorry for forget to specify the info about the server.

    Server is running on RH AS4 , OpenEdge 10B.

    We have tried to restart the server but the problem still same.

    We refer to the ProKB , it only suggests us to increase -n parameter but we are not sure how to set it in the Progress Explorer(Admin Server)

  • In Progress Explorer, pick the defaultConfiguration properties, and set 'Maximum Users' which is the equivalent of -n.

  • I think you ran the limit of number of semaphores allowed on the OS. Each OS has its own limitations depending on CPU (32bit/64bit). Check out the progress kb on limitations. The number 12 rings a bell from when I was reading up on this stuff since i too am moving off of AIX and going to Linux AS 4.