sql92 and odbc settings (-L locktable overflow) - Forum - OpenEdge RDBMS - Progress Community

sql92 and odbc settings (-L locktable overflow)

 Forum

sql92 and odbc settings (-L locktable overflow)

  • I'm getting a whole heap of these under 10.1B which i didn't have under 10.1A. Now, I've probably borked something when setting up the sql odbc under windows 2003 server and linux.

    the windows box only does READ-ONLY operations (crystal reports / excel) etc.

    What settings should I have in a DSN string?

    the linux box CREATES/UPDATES records, but in a single SQL statement. Is there anything I should have in the /etc/odbc.ini file ? Is there an option to automatically start and end a transaction for every statement ?

  • Have you configured the ODBC connection to use READ-UNCOMMITTED?

  • READ-UNCOMMITTED. dammit.

    I have REPEATABLE READ

    So, there is a "-" between the words as well. Didn't spot that. I'll let you know how I get on. Many thanks

  • So, there is a "-" between the words as well.

    Don't quote me on that. The Windows ODBC configuration actually says "READ UNCOMMITTED" (space instead of the hyphen)

  • I put a - in the windows as well and it seems to work