Unable to open word-break table file 5. (2736) - Forum - OpenEdge RDBMS - Progress Community

Unable to open word-break table file 5. (2736)

 Forum

Unable to open word-break table file 5. (2736)

  • Hi, Everybody, when I try to connect OpenEdge Database through "Data Administration" tools of OpenEdge Release 10.2A, I countered an error message "Unable to open word-break table file 5. (2736)", it fails to connect, and I got the same error message when I run "Prostrct repair ". but it works well with "Data Administration" of OpenEdge Release 10.1B, Is there any setting wrong with the new environment  of OpenEdge Release 10.2A? Would anybody advise me how to fix it? Thanks very much in advance!!!

  • Copy the proword.5 file from the 10.1B DLC directory to the DLC directory of the other version. That file is missing.

  • It is great, Now it can be connected after copy the proword.5 file as you adivsed. Mike Fechner, thanks a lot !!!

  • You're welcome!

    Custom word break tables can be a great tool. But it happened to me a number of times that I've receive DBs from a customer and I couldn't do anything with it because I didn't receive the WBT.

  • After adding this database into the localhost by Progress Explorer Tool (defaultConfiguration->defaultServerGroup->Property: Port Number: 6025, Number of Server: 1, Maximum clients per server: 1, Minimum clients per server: 1), but when I tried to start this Database from Progress Explorer Tool, I got "Error in startup of database... Message: time BROKER :** This process terminated with exit code 1. (8619)(JUNMsg024)". Is there any wrong setting with "defaultConfiguation"? Any help would be greatly appreciated.

  • Hello, Mike Fechner, Would you mind to give me some advice to fix this problem? Your kindly help would be greatly appreciated!!!

  • There is nothing wrong with using the default configuration. 99% of all Databases I've seen are configured that way.

    Do you have any more information in the databases log file (databasename.lg in the same folder as the .db file)? If not, that might be an indication that the path to the database is wrong in Progress Explorer.

  • Also check your admserv.log file (probably under the working directory you selected during installation of OE) for messages.

    They can also share a light on "Progress Explorer" issues...

    If you have your db already running, you get the error message you're describing.

    But avoid running a 10.1 database with an AdminServer 10.2. The AdminServer will start the database with 10.2 commands.

    This leads to a different shared memory segment.

    Although it's possible I guess it will not be fully supported by Progress.

  • Thanks very much for the kindly help of both Mike Fechner and David Kerkhofs.

    Yes, I have the databases log file in the same folder as the .db file and admserv.log file under the working directory of OpenEdge. Probably I need to upgrade my database to 10.2 to aviod this problem.

    Thanks once again !!!

  • Any suspicious messages in the log files?