Batch incremental / dump_inc.p - Forum - OpenEdge RDBMS - Progress Community

Batch incremental / dump_inc.p

 Forum

Batch incremental / dump_inc.p

This question is not answered

Hello all,

I've been playing with prodict/dump_inc.p to generate the delta for the DB updates that I need, and I have a behavior that looks different than it should.

If I set DUMP_INC_INDEXMODE to inactive (ou unset it, since it's the default), shouldn't ALL the indexes created in the delta file have the INACTIVE directive?

I've created two sets of sports2000 copies, created an index in one of them, run the utility, but it ALWAYS create the index without the INACTIVE keyword. And in incrdump.e it shows the INDEXMODE as inactive correctly.

Why does it happen? Bug on this version, or is there a case that it thinks it's ok not to respect the option and make the index active anyway?

Running 11.6.3 on Linux.

Thanks!

All Replies
  • Is your new index unique ?

    I think inactive is only applied to unique indexes.

    You could create the df with all indexes active and add "  INACTIVE" to all add index entries in the df file. Not too difficult with sed or awk

  • It's not. The docs never say a thing about that:

    DUMP_INC_INDEXMODE — Index-mode for newly created indexes; allowed values are active or inactive

    I've done the change in the .df with perl already to make it work the way I need.