Who get proadsv to re-read ubrokers.properties - Forum - OpenEdge RDBMS - Progress Community

Who get proadsv to re-read ubrokers.properties

 Forum

Who get proadsv to re-read ubrokers.properties

This question is answered

Openedge 11.3.2

RHEL 6.

A bad edit was made to ubroker.properties for a app server.

They stopped our App (qad) to do some db changes. Then started it up. I assume they stopped all app servers.

About 12 hours later the users started complaining. I found the faulting property and fixed it (deleted) in ubrokers.properties).

But the app server still wont start. Nothing in the logs (broker or server).

$ asbman -name qadwsa_ASlive -start
OpenEdge Release 11.3.2 as of Mon Jan 27 16:30:16 EST 2014


Connecting to Progress AdminServer using rmi://localhost:20931/Chimera (8280)
Searching for qadwsa_ASlive (8288)
Connecting to qadwsa_ASlive  (8276)
Unable to start qadwsa_ASlive (8297)
$

The only error I can see is in cmdplugin.log

RMI TCP Connection(461127)-160.222.139.159>(Nov 13, 2017 11:30:49:503) User: clove connecting to AdminServer (8321)
RMI TCP Connection(461127)-160.222.139.159>(Nov 13, 2017 11:30:49:528) clove: Executing command (8324)
RMI TCP Connection(461169)-160.222.139.159>(Nov 13, 2017 11:34:17:509) User: mfg connecting to AdminServer (8321)
RMI TCP Connection(461169)-160.222.139.159>(Nov 13, 2017 11:34:17:530) mfg: Executing command (8324)
RMI TCP Connection(461169)-160.222.139.159>(Nov 13, 2017 11:34:17:532) Unable to start qadwsa_ASlive due to Invalid property name: "qadwsa_ASlive". (PRPMsg009) in  UBroker.AS.qadwsa_ASlive
RMI TCP Connection(461169)-160.222.139.159>(Nov 13, 2017 11:34:17:532) Unable to start qadwsa_ASlive (8297)

And yes qadwsa_ASlive was the property they added. (no idea what they were trying to do). The bad edit was

qadwsa_ASlive=3

Back to my problem. I am assuming "it" has cached a copy somewhere. ($DLC/bin/asconfig -name qadwsa_ASlive comes back clean).

I really, really don't want to kicked everyone off to restart the admin server.

Is there any clever way force the admin server to re-read the ubrokers.properties?

Any comments welcome.

Cheers

Craig  

Verified Answer
  • Hi Craig,

    you could try using the mergeprop command from PROENV to export and then update the ubroker. Under windows this updates the properties file and causes the admsrv to reload it.

    The other method, at least with windows, is to stop/start the admsrv from a PROENV with switches to keep the services running. Search the KB for "How to restart the AdminServer without stopping ubrokers".

    Cheers

    Tony.

All Replies
  • Hi Craig,

    you could try using the mergeprop command from PROENV to export and then update the ubroker. Under windows this updates the properties file and causes the admsrv to reload it.

    The other method, at least with windows, is to stop/start the admsrv from a PROENV with switches to keep the services running. Search the KB for "How to restart the AdminServer without stopping ubrokers".

    Cheers

    Tony.

  • Thanks Tony. The Knowledge base entry sorted me out. It took it's time but got there in the end :)