Pro2 5 testing - Forum - OpenEdge Pro2 - Progress Community
 Forum

Pro2 5 testing

This question has suggested answer(s)

Testing Pro2 v5 - getting error when running replBatch unknown database name repl. My repl tables are embedded in source database.

OE 11.4

PRO2 v5

All Replies
  • Hi

    You need to modify your predefs.i, which is in your Pro2 folder as below

    &GLOBAL-DEFINE Embedded_ReplTables CREATE ALIAS Repl FOR DATABASE {Your Source-dbname}

    &GLOBAL-DEFINE ReplDB {Your Source-dbname}.    /*This line and Embedded_ReplTables line need to be changed for embedded repl */

    Please let me know if you still face some issue.

  • thanks

    I comment out RplDB Repl and added create alias

    /* Standard Preprocessor Definitions have been included */

    &GLOBAL-DEFINE Embedded_ReplTables /*CREATE ALIAS Repl FOR DATABASE {Source-dbname}.*/

    /*&GLOBAL-DEFINE ReplDB Repl.  */  /*This line and Embedded_ReplTables line need to be changed for embedded repl */

    &GLOBAL-DEFINE CODE_DIR bprepl/

    &GLOBAL-DEFINE COMMON_DIR common/

    &GLOBAL-DEFINE COMMONINCL_DIR {&COMMON_DIR}includes/

    &GLOBAL-DEFINE DB_DIR db/

    &GLOBAL-DEFINE DELTRIG_DIR {&CODE_DIR}repl_d/

    &GLOBAL-DEFINE IMAGE_DIR {&CODE_DIR}images/

    &GLOBAL-DEFINE INCLUDE_DIR {&CODE_DIR}repl_inc/

    &GLOBAL-DEFINE LOG_DIR {&CODE_DIR}repl_log/

    &GLOBAL-DEFINE MASSREPL_DIR {&CODE_DIR}repl_mproc/

    &GLOBAL-DEFINE MASSVER_DIR {&CODE_DIR}repl_mver/

    &GLOBAL-DEFINE REPLPF_DIR {&CODE_DIR}repl_pf/

    &GLOBAL-DEFINE REPLPROC_DIR {&CODE_DIR}repl_proc/

    &GLOBAL-DEFINE SCRIPT_DIR {&CODE_DIR}Scripts/

    &GLOBAL-DEFINE TMP_DIR tmp/

    &GLOBAL-DEFINE TEMPLATE_DIR {&CODE_DIR}repl_tmpl/

    &GLOBAL-DEFINE VERPROC_DIR {&CODE_DIR}repl_ver/

    &GLOBAL-DEFINE WRITRIG_DIR {&CODE_DIR}repl_w/

    &GLOBAL-DEFINE USE_APPSRV  NO

    &GLOBAL-DEFINE APPSRV_NAME Pro2AppSrv

    &GLOBAL-DEFINE APPSRV_-H-S -H ??????? -S 4320 -clientConnectTimeout 120    /*4.6.7 - Added clientConnectTimeout*/

    &GLOBAL-DEFINE SCHEMAHOLD ?????sh

    &GLOBAL-DEFINE SOURCEDB NO

    &GLOBAL-DEFINE SOURCEDB2 NO

    &GLOBAL-DEFINE SOURCEDB3 NO

    &GLOBAL-DEFINE SOURCEDB4 NO

    &GLOBAL-DEFINE ENABLE_OE_CDC No

    CREATE ALIAS Repl FOR DATABASE  value(ldbname("carolina")).

  • Is it working ?