PASOE Launch Configuration - Forum - Kendo UI Builder - Progress Community

PASOE Launch Configuration

 Forum

PASOE Launch Configuration

This question is answered

What is the publish directory? I'm running 11.7, maybe 11.7.1 I don't think it's 11.7.2 

I tried setting it to dlcwork/oepas1 no joy. I tried dlcwork/oepas1/openedge , no joy.  I tried dlcwork/oepas1/webapps , no joy.

If I don't use the launch configuration, I can get the PAS started, but it doesn't have the right propath and my app won't run.

Verified Answer
  • The config file you are looking for is oepas1/conf/openedge.properties and contains the PROPATH entries. I would suggest making a copy of this file before making any further changes, just so you have an original state to refer back to. How were/are you changing the propath? Typically this can be done through the configuration editor in PDSOE for the server instance.

All Replies
  • - the publish dir shouldn't prevent you from starting the server (but i'm conscious of theory-vs-practise)

    - what do you consider the right config? the one in the instance's conf/openedge.properties should (IMO) be the right one

    - Make sure you set the flag for dev studio (PDSOE) to respect the server config (it's in preferences : Progress OpenEdge > Server > UPdate properties from server before starting.  I'm not 100%  sure that this is used for PASOE but it's vital for Classic AppServer IMO

    - The "Publish Dir" should be the instance's openedge/ folder , since it's in propath by default.

  • Greg, let's start from the beginning. Have you created a new PAS instance for your project, or are you utilizing the oepas1 that came "out of the box" with your OE installation? For the former, where did you create the instance. If the latter, do you want to continue to use that or would you prefer to create your own dedicated instance in a location of your choosing?

  • I didn't create anything. This oepas1 was on the system given to me, I assume it's the one that came with the install, but I really don't know.

  • Correct, oepas1 is set up by default for you as part of the OE install. You're free to use this, but means your server is buried in your DLC_WRK directory. So assuming the default location, the deployment location for your projects will be the /webapps/ folder of the oepas1 instance.

  • Peter, I don't know what I consider the right config. Right now the server runs with a script which calls call tcman start -I oepas1. When this runs, everything is fine, except that the server doesn't have the right propath. I cannot find an entry on the Explorer for oepas1 whcih allows me to change the propath. The configuration is considerably different from what I was used to in the past.

  • The config file you are looking for is oepas1/conf/openedge.properties and contains the PROPATH entries. I would suggest making a copy of this file before making any further changes, just so you have an original state to refer back to. How were/are you changing the propath? Typically this can be done through the configuration editor in PDSOE for the server instance.

  • This is what I get when I try to restart from the servers tab:

    C:\xyz\psc\oe\11.7\dlcwork\oepas1\logs\oepas1.2018-02-28.log:2:15:48:47.417/2163 [localhost-startStop-1] ERROR c.p.a.s.security.OEMetadataSource - restOEMetadataSource: Error reading intercept-url source file

    C:\xyz\psc\oe\11.7\dlcwork\oepas1\logs\oepas1.2018-02-28.log:40:15:48:47.418/2164 [localhost-startStop-1] ERROR c.p.a.s.security.OEMetadataSource - restOEMetadataSource: Error loading intercept-url source file: abort

    C:\xyz\psc\oe\11.7\dlcwork\oepas1\logs\oepas1.2018-02-28.log:78:15:48:47.419/2165 [localhost-startStop-1] ERROR c.p.a.s.security.OEMetadataSource - restOEMetadataSource: Error during load of csv intercept-url configuration: restOEMetadataSource: Invalid line format(4) in CSV file at line number 1

    C:\xyz\psc\oe\11.7\dlcwork\oepas1\logs\oepas1.2018-02-28.log:80:15:48:47.423/2169 [localhost-startStop-1] ERROR o.s.web.context.ContextLoader - Context initialization failed

  • If you change this via Progress Explorer, PDSOE, ensure you do so in the second level of configuration. So click on the name of the Progress App Server from the resource menu, then don't click on the top level of configuration, instead click on the name of your application, under 'Abl Applications', then click on this configuration and you should see the PROPATH and you should be able to edit it here. You'll see Agent Working Dir, Agent Startup Params and then PROPATH.

  • I see the openedge.properties file, I also see about 80 openedge.properties.PROJECTNAME-d.999999999999 files.

  • Those are just incremental backups. Those are made after any significant change to your project during a publish. Believe me, they can be a lifesaver.

  • This looks like it could be a possible syntax error in your oeablSecurity.csv file. We might have to see the contents to help further.

  • I edited the appserver.properties file, set the correct propath and now things are working. Thanks.