KUIB german 'Umlaute' are not shown correctly - Forum - Kendo UI Builder by Progress: OpenEdge Edition - Progress Community
 Forum

KUIB german 'Umlaute' are not shown correctly

This question is not answered

Hello,

I implemented kendo.messages.de-DE.js in the folder resources\webapp\scripts\kendo.messages.de-DE.js 

Now there are german texts for the filter selection etc., but then Umlaut-characters ä ö ü ß are not ok.
The codepage of the file resources\webapp\scripts\kendo.messages.de-DE.js ist ISO8859-1 (ANSI).

The codepage of the file build-output\debug\scripts\kendo.messages.de-DE.js is unknown - it is neither ISO8859-1 nor UTF-8.

So what's to do, to get nice "Umlaut"-characters`?

Many thanks.

Wolfgang

All Replies
  • Hello Wolfgang,

    I took a look at this and I was not able to reproduce the issue.

    I added kendo.messages.de-DE.js (from github.com/.../messages) and I was able to see the message "Einträge 1 - 9 von 9" when using a grid.

    I took a look at the JavaScript file and I noticed that ä is stored as \303\244 which UTF-8.

    I also tested by editing the file and adding the other characters that you mentioned to the message and they worked.

    Do you see the right message for Einträge / von when using a grid?

    If you use the web inspector, do you see the right value for the character in the source file?

    We would need to figure out where the character is not being process correctly.

    I hope this helps,

    Edsel

  • Hey Wolfgang,

    I think the most important question is how you put the messages file there. Did you save it there using a text editor, and if so, what encoding is that text editor set to? If you took the file straight of the github repo it is UTF8 by default.

    So to directly answer your question - open the messages file in a text editor of your choice (e.g. notepad++), set the encoding to UTF8 and save it again :) Should be all good then.

    Cheers

    Julian