.net open client from 64-bit error - Forum - OpenEdge General - Progress Community

.net open client from 64-bit error

 Forum

.net open client from 64-bit error

  • We have had .Net Open Clients (proxygen and AppServer) working fine for a while, but now we've got a couple of people with new 64-bit machines who get an error when they try to use the client:

    ... Error: Could not load file or assembly ... Progress.ssl, Version=10.2.0.35934 ...

    This is with .Net 3.5. I think both 64-bit machines are Vista (which wasn't a problem in 32-bit), and we checked that both of those machines have .Net 3.5.

    Any suggestions?

  • Hi John,

    This is a known issue and will be addressed in 10.2B FCS.  Sadly, the fix did not make it into the beta release.

    EDIT:

    My assumption was that this was based on 10.2B Beta - just to clarify this issue is fixed in the 10.2A02 Service Pack also.  Sorry for the confusion.

    Regards,

    Tom

  • I got around this issue by setting the Build Platform to x86 in the project properties/build tab. That fixed my problem for a .NET 3.5 service that was running on a 64 Bit server. It will cause .NET to operate as a 32-Bit process regardless of the OS being 32-Bit or 64-Bit.