OE 10.2b: Add Components problem - Forum - OpenEdge General - Progress Community

OE 10.2b: Add Components problem

 Forum

OE 10.2b: Add Components problem

  • Hi,

    if I try to add a component to my OpenEdge 10.2b installation, I always get a message that setup.exe and some dll-files are running.

    I rebooted my system and tried it again with the same result.

    Can anyone help me?

    Reagards,

    Malte

    setup.jpg

  • Try ProcessMonitor to find where it is starting and/or just kill the process..

  • Ok I tried it but there was only one setup.exe. I killed it and my "Add Components" dialog was closed. So I think the blocked files are from my "Add Components" dialog. Got same problem with "License Update" dialog.

    Is this a bug on my installation or can someone reproduce it on his/her system?

  • Hi Malte,

    I have reported this problem more than once but TS could never reproduce it.

    The only solution I found was to physically delete the named dll components in the %DLC% directory and completely reinstall everything. Make sure you backup any properties and plugins before you do that.

    Make sure you report the problem before reinstalling.

    P.S. Just to be on the safe side: I assume none of your AdminServices are set to Automatic (so they won't start after a reboot)?

    -peter

  • Hi Peter,

    this are bad news but I will report it also to progress. I hope they can reproduce it and fix it. If I get a fix/workaround from progress I will post it here.

    P.S.: yes all my adminservices are down.

    Regards,

    Malte

  • I am able to replicate this too (10.2B, Win7 64bit). However, you do not need to uninstall everything. Just re-run the setup.exe from the original media and the installer will work without an issue (after warning you that you can only install to the previous directory, as expected).

  • Thank you very much!

    I executed the setup.exe from the original media and registered only my new component. After this I checked my installed licenses and there are all my "old" components and my new component, too.

  • I always install from the original media so that was not my problem.