ASP.NET / Openedge Open Client / 64bit - Forum - OpenEdge General - Progress Community

ASP.NET / Openedge Open Client / 64bit

 Forum

ASP.NET / Openedge Open Client / 64bit

  • Community ,

    We got an application with front-end in ASP.Net, backend in Openedge 10.2A03

    We are installing the whole application on a server with OS Windows 2003 Server, 64 bit

    When we browse the application on that machine we got an error : Unable to load 'Progress.ssl' or one of its dependencies ... invalid format

    Application is made with Visual Studio 2008 on 64 bit machine, the proxygen dll's also.

    I guess this has something to do with 32 to 64 bit comptability.

    What I tried so far :

    - Mark the Proxygen executable as 32 bit application (P133126)

    - Mark the project in Visual Studio 2008 to be running on a x86 platform (via Web solution properties - Build tab)

    - Add following line to xpxg

         <DotNetSwitches>/platform:x86</DotNetSwitches>

    nevertheless, nothing seems to be helping

    Anyone a clue ?

    Gerd

  • Hi Gerd,

    It sounds like you are running into a issue that I thought was fixed in 10.2A02/10.2B.  You mention that the backend is running 10.2A03, is the .NET Open Client connecting to the backend also version 10.2A03?  Thanks.

    Matt

  • Yes, both 10.2A03.

    We are planning to migrate to 10.2B by the end of the summer.

    On Thursday I have a meeting with a consultant who had this before, and we are going to try out his solution.

    I'll keep this issue updated with the possible solution

    Kind regards

    Gerd

  • Thanks Gerd.

    I have a couple of questions if you don't mind.  The application you are installing on the 64-bit Windows machine, was it running on a 32-bit machine previously?  Also, was the application run prior on an earlier OpenEdge version than 10.2A03?  Thanks again.


    Matt

  • No, I don't mind !!

    The application was tested with 10.2A02 on 32 bit machine.

    But the webserver at our client was 64 bit, so we needed some magic

    We are now going to perform tests on Windows 2003 Server 64 bit and Windows 2008 Server 64 bit.

    Gerd

  • Gerd,

    Thanks.

    From the description you have given this is something that should work and I thought was fixed.  Could you please contact OpenEdge Tech Support and log a bug?  Thanks again.

    Matt

  • Gerd,

    The fix for the problem that I thought was causing your problem is in Progress.o4glrt.dll.  Is it possible for you to see if that was updated when you installed the 10.2A02/03 service pack?  Thanks.


    Matt

  • The solution was to mark ISS to be able to handle 32bit applications

    Gerd