Is there a way to disable the native grouping of ABL traditional windows for an App that mixes both traditional and .Net windows? - Forum - OpenEdge General - Progress Community

Is there a way to disable the native grouping of ABL traditional windows for an App that mixes both traditional and .Net windows?

 Forum

Is there a way to disable the native grouping of ABL traditional windows for an App that mixes both traditional and .Net windows?

This question is answered

OE 11.6.2  Our App uses a mix of both ABL traditional windows and .Net windows. This issue is pretty annoying as we try to move PROGRESSively toward modern UI with .Net stuff

Say we launch these 3 windows in this order:

AblWin1 spreads on half of a screen on the left side

AblWin2 spreads on half of a screen on the right side

.NetWin3 also spreads on half of a screen on the right side, on top of AblWin2

At a point, the user want to do something in AblWin1 on the left, but keeping .NetWin3 visible because he needs to read something in it.

Sadly, as soon as he clicks in AblWin1 then the native grouping of ABL traditional windows moves AblWin2 on top of .NetWin3

So far, we managed to live with it, and some people manage to accommodate this situation with multiple screens, but some are getting tired of it.

Q1: is there a known technique to tell the ABL to no longer group its traditional windows and let us do the job?

Q2: are there other people around the world struggling with this problem?

TIA

/S

Verified Answer
  • You can add the -nozgrouping startup parameter or add NoZGrouping=yes in the Startup section of the registry or ini file to disable the grouping. Or display a form before displaying any ABL windows. The latter is why most applications don't encounter this issue - if you display a form the AVM disables grouping of any ABL windows which are subsequently displayed. Most applications display a "main" form first so grouping is disabled automatically from the start.

    There's an explanation of the behavior in my first post in this thread:

All Replies
  • You can add the -nozgrouping startup parameter or add NoZGrouping=yes in the Startup section of the registry or ini file to disable the grouping. Or display a form before displaying any ABL windows. The latter is why most applications don't encounter this issue - if you display a form the AVM disables grouping of any ABL windows which are subsequently displayed. Most applications display a "main" form first so grouping is disabled automatically from the start.

    There's an explanation of the behavior in my first post in this thread:

  • Sounds pretty promising Matt.  Thank you.  I will test it soon

  • -nozgrouping does the job indeed.  Thank you for your prompt reply Matt, this has made my day.

    To answer your point, now I see why our Appllication hits this issue despite the the ABL can automatically disable Z-grouping if a .NET form is displayed at first in an ABL session : We do use NET winForm but only WPF components

    At last, I can see -nozgrouping is refered in a KBase as an undocumented startup param.  I believe we would be better to make it appear in the official documentation.  I will probably suggest it to support