AppServer error - Version 11 of the server can not accept incompatible client version 9. (12330) - Forum - OpenEdge General - Progress Community

AppServer error - Version 11 of the server can not accept incompatible client version 9. (12330)

 Forum

AppServer error - Version 11 of the server can not accept incompatible client version 9. (12330)

This question is not answered

Hello everyone,

We have here na aplication that conect with our AppServer.

But, when we try a conection, pop up an error on AppServer log “Version 11 of the server can not accept incompatible client version 9. (12330)”

What that means? And how we can fix it ?

All Replies
  • From ProKB:

    "Client and AppServer do not always have to have the exact same version, but they must be compatible versions.  If you get this message, you may have to upgrade one or the other to match."

    Was your AppServer platform recently upgraded to a newer version of OpenEdge 11.x?  Or is a v9 client now connecting to it, which wasn't previously?

  • What is the client? Is it a Progress 4GL program that is running? Or something else?

    If Progress, then what version of Progress is the client running? Compatibility is only one version back.

    If it is a java application, then you probably have an old o4glrt.jar.

    Paul

    Paul Koufalis
    White Star Software

    pk@wss.com
    @oeDBA (https://twitter.com/oeDBA)

    ProTop: The #1 Free OpenEdge DB Monitoring Tool
    http://protop.wss.com
  • There is a version mismatch in between your client and AppServer. Can you please mention what are your client and AppServer versions?