PASOE fails to start with a port conflict of a port not appearing in any conf/* file. - Forum - OpenEdge General - Progress Community

PASOE fails to start with a port conflict of a port not appearing in any conf/* file.

 Forum

PASOE fails to start with a port conflict of a port not appearing in any conf/* file.

This question is answered

I am  trying to start a PASOE instance on our development server.

The service fails with the following message in catalina.out

SEVERE [main] org.apache.catalina.core.StandardServer.await StandardServer.await: create[localhost:8005]:
java.net.BindException: Address already in use

This port does not appear in any of the config files, but I determined that JIRA is already using that port. If I shut down JIRA, the PASOE instance starts with no problem.

What is port 8005 used for and how can I change it?

Regards

Simon

Simon L Prinsloo

www.vidisolve.com

Verified Answer
  • that will be the shutdown port, you can change it from configuration file… https://tomcat.apache.org/tomcat-7.0-doc/config/server.html

    Marian Edu

    Acorn IT 
    +40 740 036 212

  • Thanks Marion

    On the OpenEdge Explorer screen it asks for a shutdown port, but it has a note that reads:

    NOTE: A value for shutdown port is only required on Windows. Specify -1 for the shutdown port to disable it.

    So I set it to -1. But that does not seem to work, so I changed it to something else and now everything works fine.

    Regards

    Simon

    Simon L Prinsloo

    www.vidisolve.com

All Replies
  • Make a grep for configuration

    tcman.sh config | grep 8005

    What will be found?

  • It finds nothing.

    I suspect this port some default is used by the Tomcat underlying the PASOE and JIRA.

    Simon L Prinsloo

    www.vidisolve.com

  • that will be the shutdown port, you can change it from configuration file… https://tomcat.apache.org/tomcat-7.0-doc/config/server.html

    Marian Edu

    Acorn IT 
    +40 740 036 212

  • Yes, this is the shutdown port for Tomcat. Standart ports for tomcat is 8005, 8080, 8009.

    so it's strange to me that you did not find 8005 port in the configuration of your PAS instance.

    How did you create your instance?

  • Thanks Marion

    On the OpenEdge Explorer screen it asks for a shutdown port, but it has a note that reads:

    NOTE: A value for shutdown port is only required on Windows. Specify -1 for the shutdown port to disable it.

    So I set it to -1. But that does not seem to work, so I changed it to something else and now everything works fine.

    Regards

    Simon

    Simon L Prinsloo

    www.vidisolve.com

  • I specified -1 as the shutdown port, since the note on the config page says it is only needed on Windows and can be set to -1 to disable it. So my config had -1, yet tomcat still used 8005, so I think the note is wrong.

    Simon L Prinsloo

    www.vidisolve.com

  • I just created through OE Management two instances of PAS on CentOS 7 without a shutdown port (-1) and started them without problems . I use OpenEdge 11.7.1.

    What version do you use?

  • Simon, it might depend on the tomcat version used there (by PASOE or Jira)… there is also a note that might apply in your case.

    Note: Disabling the shutdown port works well when Tomcat is started using Apache Commons Daemon(running as a service on Windows or with jsvc on un*xes). It cannot be used when running Tomcat with the standard shell scripts though, as it will prevent shutdown.bat|.sh and catalina.bat|.sh from stopping it gracefully.

    Marian Edu

    Acorn IT 
    +40 740 036 212