Developer studio problem.... - Forum - OpenEdge General - Progress Community

Developer studio problem....

 Forum

Developer studio problem....

This question is not answered

It looks for me like "since forever".

the problem is I cant add triggers to objects in UI windows. (since 11.0 or so)

I've used all tips: ceate new project, and import sourcecode.  don't use text widgets in window, upgraded to 11.7, create new window and imnport all widgets from old window, but still have to open the original destop , and use the AppBuilder to add triggers to widgets and then finish on Studio, as it not possible to get a trigger on studio for menu bar options for instance..

Is there something I'm doing wrong?

Thanks

All Replies
  • For work on windows / dialogs I still use the AppBuilder. I find it much more convienient than Eclipse for these things. When I try to add a trigger to a widget (11.6), I right-click the widget, select 'Add Trigger' and then Eclipse switches to code view. And then nothing happens. I expected some kind of dialog to specify what trigger I would like to add, but the code comes into view and that's it. In the code, I can should be able to add a trigger using ALT+SHIFT+G but that also does nothing. 

    Looks like a bug...

  • Similar kind of issues were addressed in 11.6.3.009 and 11.7. Could you please provide us the following details to replicate the problem in our environment?

    1. Exception trace from <workspaceLoc>\metadata\.log file.

    2. Is it specific to any widget? From your words, It seems that the problem is seen only when adding widgets from old version windows to newly created ones. Please confirm. If so, from which version of window, the widgets are copied from?

    -Divyatheja

  • 1) I deleted content on .LOG, and run the creation of trigger, but it won't generated exception on .log, neither it created the options and menu widget on the screen that pops up ("Add trigger").

    The widget combo is empty , but there are listed remainder widgets and fields in browsers. (the menu widgets are not listed).

    2) the window is:

    &ANALYZE-SUSPEND _VERSION-NUMBER AB_v10r12 GUI   (first line on file), and normally, the widgets are not copyed, they are created from the tool box directly..

  • We had also a similar problem with the option "Apply keywords casing on save" (Lower Case) this corrupts the AppBuilder wizard for automatic creation of triggers(fill-in).

    PSC00358138

  • I've got the same problem with "add trigger". It worked in 11.5 Dev Studio. OE 11.6.3 forces using AppBuilder again.