PASOE config inconsistency between Windows & Linux - Forum - OpenEdge General - Progress Community

PASOE config inconsistency between Windows & Linux

 Forum

PASOE config inconsistency between Windows & Linux

This question is answered

Hi!

OE 11.6.3 x64 on Windows 10 and Ubuntu server 16.04.

When I create a PASOE instance on both platforms with: 

tcman.sh (or .bat) create -p ... -P ... -s ... -N as-oerest-dev1 ./as

and then 

as/bin/tcman.sh (or .bat) deploy -a testapp <DLC>/servers/pasoe/extras/oeabl.war 

Then all the configuration settings in conf/openedge.properties look like this on Linux:

[as-oerest-dev1.testapp]
  statusEnabled=1

[as-oerest-dev1.testapp.APSV]
  adapterEnabled=1

etc

However, if I look the same settings on windows, they look like:

[as.testapp]
  statusEnabled=1

[as.testapp.APSV]
  adapterEnabled=1

etc

This is kind of annoying because when I want to change these settings via oeprop I have to address the same property for the same ABL Webapp in two different ways. I would consider this a bug. What would you guys think?

Verified Answer
  • Aha! I don't use the instance name in the tcman deploy. 

    The help states:

    $ bin\tcman.bat help deploy
    usage: tcman deploy [options] -u <uid:pwd> [-a <app-name>] <war-file-path>

    The help doesn't even mentions that possibility...

    So when I deploy an ABL webapp I use the following:

    bin\tcman deploy -a testapp %DLC%\servers\pasoe\extras\oeabl.war

    without the instance name. Ok, that doesn't explain btw why there's a difference between Linux and Windows because I used the same tcman deploy twice.

All Replies
  • Smells buggy

    Sent from Nine

    Von: bronco <bounce-bfvflusso@community.progress.com>
    Gesendet: 11.01.2017 1:52 nachm.
    An: TU.OE.General@community.progress.com
    Betreff: [Technical Users - OE General] PASOE config inconsistency between Windows & Linux

    Update from Progress Community
    bronco

    Hi!

    OE 11.6.3 x64 on Windows 10 and Ubuntu server 16.04.

    When I create a PASOE instance on both platforms with: 

    tcman.sh (or .bat) create -p ... -P ... -s ... -N as-oerest-dev1 ./as

    and then 

    as/bin/tcman.sh (or .bat) deploy -a testapp <DLC>/servers/pasoe/extras/oeabl.war 

    Then all the configuration settings in conf/openedge.properties look like this on Linux:

    [as-oerest-dev1.testapp]
      statusEnabled=1

    [as-oerest-dev1.testapp.APSV]
      adapterEnabled=1

    etc

    However, if I look the same settings on windows, they look like:

    [as.testapp]
      statusEnabled=1

    [as.testapp.APSV]
      adapterEnabled=1

    etc

    This is kind of annoying because when I want to change these settings via oeprop I have to address the same property for the same ABL Wepapp in two different ways. I would consider this a bug. What would you guys think?

    View online

     

    You received this notification because you subscribed to the forum.  To stop receiving updates from only this thread, go here.

    Flag this post as spam/abuse.

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • What is definitely is a bug is that on Windows in OEM when I click the ABL application "as-oerest-dev1" there's is only 1 ABL WebApp listed: ROOT (not testapp). On Linux there are two ABL WebApps listed: ROOT & testapp. I'm going to contact TechSupport on this.

  • Hi Bronco,

    Please contact techsupport. I will try to reproduce the problem at my end.

    Regards,

    Irfan

  • I actually did, the case number is: 00383135

    In fact it's two cases in one: one for the difference in the config files and one for the ABL Webapp not showing up in OEM. These might be related however.

  • Thank you

    Regards,

    Irfan

  • Bronco,

    I tried to create the instance similar to what you have done and it kind of worked fine to me.

    pasman create -p 2411 -P 2511 -s 2611 -N oe-rest-app myApp1

    tcman deploy -a temp-124 %DLC%\servers\pasoe\extras\oeabl.war oe-rest-app

    [AppServer]

       allowRuntimeUpdates=0

       applications=oe-rest-app,myApp1

       collectMetrics=1

       statusEnabled=1

    [oe-rest-app.temp-124.WEB]

       adapterEnabled=1

       defaultCookieDomain=

       defaultCookiePath=

       defaultHandler=OpenEdge.Web.CompatibilityHandler

       srvrAppMode=development

       srvrDebug=1

       wsRoot=/temp-124/static/webspeed

    OfCouse, I was testing it on Windows7 and you have tested it on Windows10 for 11.6.3.But,  I have tested the same on 117ESAP on Win10 and it seem to work fine too.

    Regards,

    Irfan

  • Aha! I don't use the instance name in the tcman deploy. 

    The help states:

    $ bin\tcman.bat help deploy
    usage: tcman deploy [options] -u <uid:pwd> [-a <app-name>] <war-file-path>

    The help doesn't even mentions that possibility...

    So when I deploy an ABL webapp I use the following:

    bin\tcman deploy -a testapp %DLC%\servers\pasoe\extras\oeabl.war

    without the instance name. Ok, that doesn't explain btw why there's a difference between Linux and Windows because I used the same tcman deploy twice.

  • for the record: if I add the instance name after the oeabl.war path I can confirm that works.

  • And to be precise: if I omit the instance name and the instance is installed in c:\temp\pasoetest1\hoppa the webapp's settings are in the openedge.properties like this:

    [hoppa.app1.APSV]            

       adapterEnabled=1        

       enableRequestChunking=1  

       useHTTPSessions=1        

    that's definitely a bug...

  • I definitely consider it as a bug, I am just trying to reproduce the problem. I will try to reproduce it as per your steps and log a bug.

    Regards,

    Irfan

  • The difference is there is a bug on Windows and not one on Linux. I see you have the workaround. You actually are not specifying the instance name. You are specifying the ABL Application name which defaults to the instance name.
     
    Dave