Why can not I load the tables in my database when I want to create a business entity? - Forum - OpenEdge General - Progress Community

Why can not I load the tables in my database when I want to create a business entity?

 Forum

Why can not I load the tables in my database when I want to create a business entity?

This question is answered

Hello,

Why can not I load the tables in my database when I want to create a business entity?

I have verified the connection to my database, and it is actually connected.

The Progress OpenEdge browser console also confirms that the database is served.

De antemano gracias por su ayuda.

Thanks for your help.

Verified Answer
  • Hi Daniel,
     
    As per the error, database ‘DWH’ is already connected (may be by different user) and as a result the database connection in PDS OE is failing. Can you please check this.
     
    Business Entity wizard in PDS OE needs a successful DB connection profile such that it will fetch all associated database tables (and populate accordingly in ‘Select a schema file’ page in Business Entity wizard page) in runtime.
     
    Thanks and Regards,
    Anil Kumar.
     
  • Hello Daniel,

    You could try refreshing the cache from the Preferences dialog: Progress OpenEdge / Advanced / Class Cache.

    I hope this helps,

    Edsel

All Replies
  • Hi Daniel,
     
    As per the error, database ‘DWH’ is already connected (may be by different user) and as a result the database connection in PDS OE is failing. Can you please check this.
     
    Business Entity wizard in PDS OE needs a successful DB connection profile such that it will fetch all associated database tables (and populate accordingly in ‘Select a schema file’ page in Business Entity wizard page) in runtime.
     
    Thanks and Regards,
    Anil Kumar.
     
  • Hello Daniel,

    You could try refreshing the cache from the Preferences dialog: Progress OpenEdge / Advanced / Class Cache.

    I hope this helps,

    Edsel

  • Thanks Anil and egarcia

    I made the instructions and corrected the problem, then it failed again and I found that my files were corrupted due to a failure on my hard disk.