Program based on OpenEdge+Progress not working over VPN - Forum - OpenEdge General - Progress Community

Program based on OpenEdge+Progress not working over VPN

 Forum

Program based on OpenEdge+Progress not working over VPN

This question is not answered

Hey all,

We have a little problem setting up our new environment. I would like to know if this is something that is normal and as so can't be done using openedge or that there is a misconfiguration somewhere. We have a program that is dependent on Openedge Progress for it's database. Now when we are at the office everything works fine and fast. However when we are out of the office we can't use the program unless we use a Terminal Server where the program is installed on.

Normally the VPN should have the same access and rights as a regular lan device in our domain. Perhaps someone of you has a clue of where we can search?

All Replies
  • Connecting to a remote database over a VPN connection has extremely poor performance. The general recommendation is to have a Windows development machine in the office that you can remote into, or to have local copies of the database on your Windows machine for development purposes.

    When you say you can't use the program, what error message are you getting? Or is it possibly just a performance side-effect?

    Tim

  • I see, at the moment we do use a Windows Server (with RDS enabled) to remote into. Our users complain about the complexity of their work flow using this system but if it's the best we can do they just have to accept it.

    To be honest I don't get an error message. In task manager it shows up as a service but never opens. But since the best practice is to use a remotely accessible machine I won't be spending time to fix or overcome this.