OpenEdge OEE/OEM redirecting me back to login.jsp in an infinite loop - Forum - OpenEdge General - Progress Community

OpenEdge OEE/OEM redirecting me back to login.jsp in an infinite loop

 Forum

OpenEdge OEE/OEM redirecting me back to login.jsp in an infinite loop

This question is not answered

We just upgraded our HP-UX installation of OpenEdge from 11.6.3 to 11.7.4.  After that upgrade, we can no longer connect successfully to OEE.

When adminserver is stopped, I get connection refused in the browser (obviously).  When admin server is started, I get an error saying I was redirected too many times.  Wireshark shows a lot of GET operations to retrieve "login.jsp" and for each of them a subsequent HTTP 302 is returned that tells me to set a cookie (assuming it isn't already in place). And in the HTTP 302 responses it also instructs a redirect to location: http://mytest:9090/login.jsp (ie the same page I was already trying to open).

Here are examples of pages I've tried.  All of them have the same behavior: infinite redirection back to login.jsp.

http://mytest:9090/login.jsp
http://mytest:9090/index.jsp 
mytest:9090/redirect.jsp
http://mytest:9090/fathom.htm
mytest:9090/.../nsinsthome.jsp

Below is a portion of the admserv.log file that seems to say things were started:

[2019/01/10@18:15:45.295-0500] [2] [Fathom]                AdminServer mytest is alive. (17240)
[2019/01/10@18:15:45.298-0500] [1] [Fathom]                Setting AdminServer mytest to Online. (17199)
[2019/01/10@18:15:45.300-0500] [1] [Fathom]                AdminServer mytest is now Online. (17200)
[2019/01/10@18:15:45.358-0500] [3] [Fathom]                Starting Fathom project. (10141)
[2019/01/10@18:15:45.375-0500] [3] [Fathom]                Starting Fathom WebServer. (10144)
[2019/01/10@18:15:45.597-0500] [3] [Fathom-WEB]            Web server configuration file exists. Loading web server configuration from /usr/oemgmt/config/fathomweb.xml
[2019/01/10@18:15:45.973-0500] [3] [Fathom-WEB]            Loading web application '/' from directory /usr/oemgmt/web
[2019/01/10@18:15:47.540-0500] [3] [Fathom]                Registering fathom extension Fathom
[2019/01/10@18:15:48.048-0500] [3] [Fathom-WEB]            Using authenticationsystem [internal] for web console logins
[2019/01/10@18:15:48.424-0500] [3] [Fathom-WEB]            Using authenticationsystem [internal] for web console logins
[2019/01/10@18:15:48.457-0500] [3] [Fathom-WEB]            Insecure HTTP request filter is disabled; insecure HTTP requests will not be redirected to HTTPS
[2019/01/10@18:15:48.642-0500] [3] [Fathom]                Fathom WebServer started. (10145)

When I query fathom -query it says "Running".

In my browser I have cookies enabled.  I've tried clearing all cookies and browser cache data without luck.  I've also tried various browsers (chrome, IE, Edge) and they all behave the same.  I've also tried connecting from different client machines.  I'm really stumped and I don't know what to do next.  I've installed OE 11.7.4 successfully on Windows many, many times.  But OEM and HP-UX really have never played very well together.  I'm not sure how to troubleshoot, or get things up and running.

  I've tried a variety of things as indicated in the following KB articles and nothing seems to work:

Any help would be very much appreciated.

Thanks, David

All Replies
  • Try clearing your browser cache.

    Sent from my iPhone

    *** added later ****

    Since I can't seem to be able to add a new entry to this thread - it would seem I have missed the fact that you cleared out the cache already in your initial email - my apologies.

    There used to be an extra parameter needed to be added to fathom.init.params for HP-UX: file.mmap.strategy=4 but on the other hand without it, it would fail to start I believe altogether. The configdb (resource db) and cachedata (graph caching) are recreated from scratch on a new install (unless you dumped and load the resource db via fathom -dump & - load).

    To completely rule out any possible influence of any cache corruption issue - you can remove content of OEM/config/configdb/ folder and also OEMWRK/cachedata/cachedb/ folder (need to stop the adminserver first). 

    You can also add -DLogLevel=5 to jvmargs of AdminServer in AdminServerPlugins.properties to bump up the logging level.
    On 11 Jan 2019, at 01:44, dbeavon <bounce-dbeavon@community.progress.com> wrote:
    <ProgressEmailLogo-png_2D00_150x42x2-png> Update from Progress Community
    dbeavon

    I'm guessing that the problem is some arbitrary error that is being obscured by a redirect.  I can't find any logs that will say what the underlying error is.  I've noticed that if I use a bogus page ("") then it will behave the same way.  Also, I haven't authenticated yet with the admin/admin credentials so it may also be trying to redirect me to the login page for that purpose, but is unable to do so for some unrelated issue.

    I'm wondering if there is some standard spring-cleaning that is needed in the OEM databases after an upgrade.  Based on the following KB, there appears to be a lot of cruft in the "orientdb" databases that are used internally.

    https://knowledgebase.progress.com/articles/Article/cachedata-directory-clear-down-000079680

    From KB: Orient databases are used by OEM since OpenEdge 11.3.  There are ... use-cases for re-creating them:

    The Orient database needs to be re-created when the version is upgraded in a newer OpenEdge version or later Service Pack

    Perhaps some of that is invalid data.  I suspect invalid data doesn't clean itself, or the KB wouldn't be here.  In particular I'm suspicious of "configdb" (<oem dlc>\config\configdb).   Maybe we'll just call tech support to try to get things up and running on the new version of OE 11.7.4.  This stuff seems like it has a lot of moving parts....

    View online

     

    You received this notification because you subscribed to the forum.  To unsubscribe from only this thread, go here.

    Flag this post as spam/abuse.