AppServer and NameServer won't start in Windows 10 Creators Update Build 1703 - Forum - OpenEdge General - Progress Community

AppServer and NameServer won't start in Windows 10 Creators Update Build 1703


AppServer and NameServer won't start in Windows 10 Creators Update Build 1703

This question is answered

Hi guys,

We are upgrading the workstations' OS from Windows 10 Anniversary Update to Creators Update (Build 1703).

After the upgrade, we have noticed that no AppServer or NameServer can be started with no logs at all, they just fail to start.

We have tried that with OpenEdge 10.2B SP08 and 11.6 SP03 use Proenv and OE Explorer.

Reverting to Windows 10 Anniversary Update has resolved the issue straight away.

I'm wondering if anyone is having the same issue and if there is a workaround?


Verified Answer
  • Hi Ibrahim,

    I encountered the exact same issue.

    try the following:

    In my solution, I use proenv to manually start Admin Services

    proadsv -start

    and then start my broker and app server

    asbman -name appservername -start

    Not ideal, but at least I can run my AppServer's


  • Ok, I have an update on this issue.

    I have installed OpenEdge 11.7 x86 and I can confirm that I need to use both workaround 2 and workaround 3 to start AppServer successfully.

    Workaround 2:

    Start the AdminServer from the command line with proadsv

    Workaround 3:

    Copy the jvmstart command from the AdminServer log file  and execute it from the proenv command line

    Running AdminService as my own account didn't work for me (I always setup AdminService this way anyway to allow access to resources over the network).

    I have no workaround for OpenEdge 10.2B08 though...

All Replies
  • this may be of interest:

  • I have just reinstalled OE10.2B SP8... I started OE Management Service from Proenv, and I was able to start AppServer from OE Explorer. This really random, I have tried that before and it wouldn't work... now it is working fine.

  • Hi Ibrahim,

    As the article above indicates this is known issue and we have been working on a fix. I tried to open a support case for you but I cannot find a 10.2B serial number under your account. I'd recommend opening a case over the phone or through the support portal so that we can provide you with a fix when it is available. We can also work through this with you to confirm it is the same issue (sure sounds like it is). If you want to provide me with your 10.2B serial number I can open it on your behalf. If you do not want to share that serial number in this public forum feel free to email me directly,



    QA Engineer II, OE Core Database


    DIRECT  +1 781 280 3064    |  MOBILE  +1 508 254 0465

  • Windows 10 (Version 1703, Build: 15063.483) seems to resolve the AppServer startup issue. :)