OpenEdge Add-In for Enterprise Architect - Wiki - OpenEdge Development - Progress Community

OpenEdge Add-In for Enterprise Architect

OpenEdge Add-In for Enterprise Architect

The OpenEdge Add-in for Enterprise Architect includes a utility which can import a .df file into a UML data model and export a UML data model into a .df file. The add-in also includes the OpenEdge MDG Technology for Enterprise Architect includes OpenEdge RDBMS data types, OpenEdge ABL data types, ABL code generation templates, ABL reverse engineering grammar, and OpenEdge-sepcific UML patterns, profiles, stereotypes, tagged values, and UML diagram settings.

Like all add-ins for Enterprise Architect, the OpenEdge Add-in is a COM component that interfaces with the EA Interop assembly. The OpenEdge Add-in is written in .NET C# and requires MS Visual Studio to modify and build.

OpenEdgeMDGSetup.msi

Comments
  • I tried installing this with EA 7.5. But it does not seem to be working:The install works fine, but the add-in is not loaded. When I run Manage Add-Ins it shows an error saying the add-in is missing.Any idea what could be wrong here?RegardsThomas

  • Hi Thomas,I installed it (using EA 7.0) and despite some errors I managed to import .df's and .p's.One thing I had to do is the following: change the registry entry for the add-in: look at HKCU/Software/Sparx Systems/EAAddins/OpenEdge and change the paths to the correct installation path; you probably changed the default one into a more suitable one for your environment, but the registration part of the installer does not take this into account I think.

  • Hi David,I am not having any luck with this. I have a feeling that the registry data that is being created is incorrect for EA 7.5.

  • Can you give the exact error message you're getting?Where did you let the installer put the files?ps: I guess we should take this conversation to a discussion...

  • I placed it in the default - C:\OpenEdgeMDG.I don't get any errors when EA starts. When I go to Manage Add-ins, I get "Error - Missing" for the OpenEdge Add-in. Nothing else.I have tried to play around with the registry settings to get the OE ones to match the ones for the Eclipse add-in - but to no avail.I have managed to get OpenEdge to show up in the Settings | MDG Technologies screen by adding the root path and the bin path of the OpenEdgeMDG installation. But it is till hsowing up as missing.

  • Hi Thomas, I started a  because I'm facing problems with the source import. You can also find the link with the document I followed to set up the Add-in.

  • I tried installing this with EA 7.5. But it does not seem to be working:The install works fine, but the add-in is not loaded. When I run Manage Add-Ins it shows an error saying the add-in is missing.Any idea what could be wrong here?Same issue here (also on default path). Tried EA 7.5 and 7.0 on Windows XP and Windows 7/64 bit.Also the registry key David regards points to the right folder.

  • One thing I had to do is the following: change the registry entry for the add-in: look at HKCU/Software/Sparx Systems/EAAddins/OpenEdge and change the paths to the correct installation path; you probably changed the default one into a more suitable one for your environment, but the registration part of the installer does not take this into account I think.David, where did you get this information from? How did you issue look like? The add-in manager of EA shows "Error - missing" for the OpenEdge add in.

  • Hi guys,I apologize for not checking in until now.  Lots going on.The problems you are encountering stem from my aborted attemp to upgrade VS 2005 to VS 2008.  After the upgrade, the OpenEdgeMDG installation project no longer registered the assemblies correctly.  I tried fixing this is VS 2008 but after I ran into other (unrelated) problems, I moved back to VS 2005.  But the assembly registration problem did not correct itself.  I believe that I may need to recreate the installation project from scratch to get through this issue.Im the meantime, the assemblies can be registered manually.  First, you need to locate the latest version of the regasm.exe utility on your.  On my PC, it is in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727.  Open up a windows command prompt, and change directory to this location.If you installed the addin in the default (C:\OpenEdgeMDG), then enter the following commands at the windows comman-line prompt:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.dllC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.Utility.dllC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Generate.dllC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Import.dllDo bother with the CodeEngineering.*.dll assemblies.  They are no longer used to perform code reverse engineering.  That is now done via EA's own reverse engineering grammar framework. Subsequently, the menu options on the addin which refer to code engineering no longer function.On a more general note, the addin is now really only good for import/export of .df files.  All forward/reverse code engineering functions have been moved to utilize EA's inherit functionalaity - the code template framework (CTF) and the RE grammar engine.  And only functionality for OO code is now being actively being worked on.I'll see if I can fix the assembly registration issue over the next few weeks.Phil

  • Hi Phil,thanks for tuning in!I followed your suggested workaround, but it does not solve the issue. I posted a screenshot at the other thread opened by David. Let me know, when you need access to my system! We can make that possible.Mike

  • Sorry for the German :-) But it says, that types have been successfully registered.C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.dllMicrosoft (R) .NET Framework Assembly Registration Utility 2.0.50727.3053Copyright (C) Microsoft Corporation 1998-2004. Alle Rechte vorbehalten.Die Typen wurden registriert.C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.Utility.dllMicrosoft (R) .NET Framework Assembly Registration Utility 2.0.50727.3053Copyright (C) Microsoft Corporation 1998-2004. Alle Rechte vorbehalten.Die Typen wurden registriert.C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Generate.dllMicrosoft (R) .NET Framework Assembly Registration Utility 2.0.50727.3053Copyright (C) Microsoft Corporation 1998-2004. Alle Rechte vorbehalten.Die Typen wurden registriert.C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Import.dllMicrosoft (R) .NET Framework Assembly Registration Utility 2.0.50727.3053Copyright (C) Microsoft Corporation 1998-2004. Alle Rechte vorbehalten.Die Typen wurden registriert.

  • I am having the same problem. Still not working....

  • Have you tried to uninstall this one and use the one in the initial project (communities.progress.com/.../DOC-6208)?I'm using that one, not the newest, and this seems to work for loading .df's. As that's the only thing they keep supporting with the Add-in, it's probably best to focus on this.Am I the only one interested in the source code for this add-in?Phillip, are you allowed to share it?

  • I left something out... There needs to be a "/codebase" at the end of each call to regasm as follows:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.dll /codebaseC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\OpenEdge.Utility.dll /codebaseC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Generate.dll /codebaseC:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>regasm C:\OpenEdgeMDG\bin\DatabaseEngineering.Import.dll /codebase

  • I had to run that from a DOS box with Admin privilegues. It looks much better! The installation issue seems solved - the Add-Ins directory shows the OpenEdge sub menu.Now I'll try the rest Thanks Phil!