How do I specify a Web client operating mode? - Forum - OpenEdge Development - Progress Community

How do I specify a Web client operating mode?

 Forum

How do I specify a Web client operating mode?

This question is not answered

I've successfully deployed a web client, but it is not working; I get an error message saying that the client operatingMode is not matching the broker operatingMode.

 

I verified that the test_AS broker is running in Stateless (which I expect), but I don't see where to specify that the client run in a Stateless mode, either in the xpxg or wsm files.  Any suggestions would be greatly appreciated .. thank you!

 

[19/12/02@15:56:06.631-0800] P-013767 T-http-8080-3 1 xxsfptexp ----------------        at java.lang.Thread.run(Thread.java:745)

[19/12/02@15:56:06.631-0800] P-013767 T-http-8080-3 2 xxsfptexp 4GL-Provider     Error in SOAP request execution: SessionPool : NoAvailableSessions[Request failure: client operatingMode does not match broker operatingMode (7251)] (10926)

[19/12/02@15:56:06.633-0800] P-013767 T-http-8080-3 4 wsa1 Message-Debug    Raw SOAP response:

[19/12/02@15:56:06.633-0800] P-013767 T-http-8080-3 4 wsa1 Message-Debug    <?xml version=''1.0'' encoding=''UTF-8''?>

[19/12/02@15:56:06.633-0800] P-013767 T-http-8080-3 4 wsa1 Message-Debug    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

 

 

 

[UBroker.AS.test_AS]

    appserviceNameList=test_AS

    brokerLogFile=/apps/qadse/test/test_AS.broker.log

    controllingNameServer=NS1

    environment=test_AS

    operatingMode=Stateless

    portNumber=1300

   

All Replies
  • You specify the mode when generating the wsm using proxygen - documentation.progress.com/.../index.html

    But... on ProgressTalk I saw that you were on 10.1C. When we implemented SOAP services (development around 10.1C, not rolled out until 10.2B) I think that state-free was the only supported option - since we changed the operating mode of our AppServers to state-free to support SOAP services.

    Looking at https://knowledgebase.progress.com/articles/Article/P174541 - session managed (which stateless is) may not be such a good idea on 10.1C.