Require-Full-Keywords and Appbuilder files - Forum - OpenEdge Development - Progress Community

Require-Full-Keywords and Appbuilder files

 Forum

Require-Full-Keywords and Appbuilder files

This question is not answered

Hello,

What is the current status of the Compile option "Require-Full-Keywords"?

The Appbuilder in OpenEdge 12.1 still produces non-compliant code.

DEFINE VAR C-Win AS WIDGET-HANDLE NO-UNDO.

DEFINE FRAME DEFAULT-FRAME
WITH 1 DOWN NO-BOX KEEP-TAB-ORDER OVERLAY 
SIDE-LABELS NO-UNDERLINE THREE-D 
AT COL 1 ROW 1
SIZE 80 BY 16 WIDGET-ID 100.
&ANALYZE-SUSPEND _CREATE-WINDOW
IF SESSION:DISPLAY-TYPE = "GUI":U THEN
CREATE WINDOW C-Win ASSIGN
HIDDEN = YES
TITLE = "<insert window title>"
HEIGHT-P = 416
WIDTH-P = 560
MAX-HEIGHT-P = 416
MAX-WIDTH-P = 560
VIRTUAL-HEIGHT-P = 416
VIRTUAL-WIDTH-P = 560
RESIZE = yes
SCROLL-BARS = no
STATUS-AREA = no
BGCOLOR = ?
FGCOLOR = ?
KEEP-FRAME-Z-ORDER = yes
THREE-D = yes
MESSAGE-AREA = no
SENSITIVE = yes.
ELSE {&WINDOW-NAME} = CURRENT-WINDOW.

Changing the templates in %DLC%/src/templates doesn't seem to work. Am I missing something? Is this Compile option not yet ready?

All Replies
  • The AppBuilder has not been modified to generate full keyword compliant code. I suggest adding this as an enhancement request to the backlog and vote for it if you believe this is important for you.