OE12 and OE11.6 conflict - Forum - OpenEdge Development - Progress Community

OE12 and OE11.6 conflict

This question is not answered


I've intalled OE12 DevStudio in quite different folders than OE11.6 to test it.

I can't use 11.6 now because of OE Exlorers conflict. Pacific 11.6 doesn't start due to bad version of OE Exlorer (localhost:9090). AdminService for OE11.6 is running and AdminService for OE12 is stopped.

Is it possible to install and test OE12 on the same computer (Win 64-bit)? How can I resolve conflict of OE Explorers on localhost 9090 port? I've tried to start and stop AdminServices. Calling Localhost:9090 gives "http 404 error".



All Replies
  • This is explained in this KB entry: knowledgebase.progress.com/.../18919

  • I eliminted ports conflict but Tomcat error still arrives.

    HTTP Status 404 – Not Found , The origin server did not find a current representation for the target resource or is not willing to disclose that one exists

  • Can you check admerv.log and find if it has recorded any errors?

  • Errors I remarked (during installation and later-starting service):


    SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".

    SLF4J: Defaulting to no-operation (NOP) logger implementation

    SLF4J: See www.slf4j.org/codes.html for further details.

    SLF4J: Failed to load class "org.slf4j.impl.StaticMDCBinder".

    SLF4J: Defaulting to no-operation MDCAdapter implementation.

    SLF4J: See www.slf4j.org/codes.html for further details.

  • OE12 and OE11.6 conflict isn't the reason, I think

  • There is a more up to date kbase that may be useful:


  • I eliminted ports conflict. Next, uninstall OE11.6

    Tomcat error still arrives.

  • Hello,

    Do you see the error accessing a particular url?

    Is this error shown only for Tomcat with 11.6 or also with 12.0?

    What happens if you only access http://<host>:8810/ ?

    (This would re-direct to static/index.html, if error 404 occurs, do you see index.html at webapps/ROOT/static?)

    I hope this helps.

  • This still looks like a port conflict issue. I would do the following things:

    Got to Windows Services -> Stop all AdminService services

    Open proenv of all the installed OE versions and do "proadsv -stop"

    Kill all java process from task manager

    Go to Windows Resource Monitor -> Network tab -> Under Listening Ports check for port 9090 (default port for OEE). If there is any associated process, note the PID and kill it from task manager.

    Then, start adminserver for the particular OE version from proenv:

    proadsv -start

    Wait till adminserver starts up

    Check fathom startup:

    fathom -query

    Wait till fathom comes up and then access  http://<host>:9090/

    If still you see a problem, I would change the port of OEE (more information here):


    Under [WebServer] add the following entry:


    Restart adminserver and access  http://<host>:9090/

  • I reconfigured OE11.6 ports from default. I can run OE11.6 Explorer but OE12 Explorer still generates the same error.

  • I've changed installation default language from polish to american. HTTP status 404 error disappeared. Fathom and OE Explorer start without problems.

  • would you mind sending me a zip of the contents of $OEM/logs/ directory. You can PM if you don't want to send them here.

  • My co-worker discovered these error in installation log:

    2019-05-31 15:15:18,675 ERROR [Fathom] [Catalina-startStop-1] - ** Failed to load license manager: Unable to instantiate license manager class com.progress.common.licensemgr.LicenseMgr: NULL

    2019-05-31 15:15:18,675 INFO  [Fathom] [Catalina-startStop-1] - Enabling OpenEdge Explorer

    2019-05-31 15:15:20,425 ERROR [Fathom] [Catalina-startStop-1] - promsgs file is not the correct version. Consult the Fathom Release notes for more information

    2019-05-31 15:15:20,425 ERROR [Fathom] [Catalina-startStop-1] - ** Progress promsgs file not compatible

  • I can send you logs Matt Baker but I don't know how. I never did it :)

  • I can send you logs Matt Baker but I don't know how. I never did it :)