PASOE Time out - Forum - OpenEdge Development - Progress Community
 Forum

PASOE Time out

This question is answered

Hi Folks,

we have a situation where we don't want to disconnect any session of application by default. e.g. If we open 3 session of my application then all three should run for unlimited time period. Default properties are set as 

idleResourceTimeout=300000

idleSessionTimeout=300000

idleAgentTimeout=0

idleConnectionTimeout=300000

We have tried by changing above properties but not clear how these are working, sometimes it worked and sometimes not. We have gone through openEdge.properties.Readme file but it does not seems to be very clear.

Could someone please provide a way so that my application does not disconnected or I can set time according my choice.

Thanks,

Ankit Agrawal

Verified Answer
  • In <PASOE Instance>/conf/web.xml, you have a HTTP session timeout. It is set to 30 mins by default, you can set that to a longer value.

    <session-config>

           <session-timeout>30</session-timeout>

       </session-config>

    Regards,

    Irfan

All Replies
  • Ankit,

    Set this value to 0 and it will not cause any timeouts. This is the default behavior.

    idleResourceTimeout=0.

    Regards,

    Irfan

  • Thansk Irfan,

    When I set it to 0 and run i am grtting below HTTP session time out error after about 45 mins idle session.

    "unable to find existing HTTP session for specified SessionID" (18328).

    An Error occurred processing the POST request: unexpected error: com.progress.appserv.broker.exception.BrokerException$SessionNotFoundException: session. (18320).

    I believe this is coming due to some other property but not sure what.

  • In <PASOE Instance>/conf/web.xml, you have a HTTP session timeout. It is set to 30 mins by default, you can set that to a longer value.

    <session-config>

           <session-timeout>30</session-timeout>

       </session-config>

    Regards,

    Irfan

  • Irfan, If we provide -1 in this parameter, will it make timeout to infinite?

  • There is a KB about using -1 in pasoe:

    knowledgebase.progress.com/.../Changing-idle-session-timeout-option-has-no-effect-in-PASOE

    I'm curious what type of client you are using? And what the failure message looks like from the client side of things?

    We used an openclient (.net) and the failure was hard to track down.  That was mainly because the exception message that surfaced in the client process was extremely generic and unhelpful, with no inner exceptions ("Communication layer message: General Error. 9998").  It sounds like you are already way beyond that part of the troubleshooting.  

    In any case, if your problems are related to the .net or java openclients, there is a kb for that too:

    knowledgebase.progress.com/.../pasoe-failures-after-a-period-of-inactivity

    We went with workaround #2 and used a very high timeout (1 or 2 days).  I think the tomcat process can handle an extremely high number of active sessions, so your timeout can be quite high.  I don't know that I would make it *infinite* unless you are also restarting tomcat on a weekly basis...

  • Thank you all for the help. it did work for me by changing in web.xml.