Progress 11.6.2 Error surrounding IHttpRequest from OpenEdge.Net.pl - Forum - OpenEdge Development - Progress Community

Progress 11.6.2 Error surrounding IHttpRequest from OpenEdge.Net.pl

 Forum

Progress 11.6.2 Error surrounding IHttpRequest from OpenEdge.Net.pl

This question is not answered

Has anyone else seen a similar error [SYSTEM ERROR: Memory violation. (49)] trying to run IHttpRequest code from AppServer ABL?

We are having an issue running IHttpRequest code from and state free AppServer

The AppServer log entries follow:

< [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- SYSTEM ERROR: Memory violation. (49) < [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- ** ABL Debug-Alert Stack Trace ** < [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- --> etl/getlogissoticket.p at line 124 (/agility/database/devel/testdb/r-code/etl/getlogissoticket.r)

< [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- ** Save file named core for analysis by Progress Software Corporation. (439) < [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- ** ABL Debug-Alert Stack Trace ** < [19/01/17@08:44:29.053-0600] P-032630 T-2183231360 1 AS -- --> etl/getlogissoticket.p at line 124 (/agility/database/devel/testdb/r-code/etl/getlogissoticket.r)

A valid example of ipcURL is:

devellogi.dmsi.com/.../rdGetSecureKey.aspx

Line 124 of /etl/getlogissoticket.r is:

goLibrary = ClientLibraryBuilder:Build():sslVerifyHost(NO):Library.

goRequest = RequestBuilder:Get(ipcURL):ContentType('text/xml;charset=UTF-8'):AcceptAll():REQUEST NO-ERROR.

                …logging code here is never executed when SYSTEM ERROR: Memory violation. (24) occurs.

ASSIGN

   goResponse = ClientBuilder:Build():UsingLibrary(goLibrary):Client:EXECUTE(goRequest).

IF VALID-OBJECT(goResponse) THEN

DO:

              …handle response; this block always seems to work fine, when it executes; when there is no  SYSTEM ERROR: Memory violation. (49)  that occurs earlier.

All Replies
  • ABL code shouldn't crash like that, especially if it's on those goLibrary and goREquest lines.

    I've see crashes in 11.6.2 in the HTTP client but they were related to setting timeouts (which you don't look to be).

    I'd contact tech support but 11.6.2 is an old release and the http client has been updated a bit since then (even 11.6.4 has quite a few changes).