File Copy over IP (Image) - Forum - OpenEdge Development - Progress Community
 Forum

File Copy over IP (Image)

This question is answered

Hi Everyone, Im fairly new to ABL developpement and have come accross a snag. Im attempting to copy and image file. So far its pretty simple just copying from a location to another Using the COPY-LOB Statement. However im needing to copy this image to a remote server with an address along the lines of http://xxx.xxx.xxx.xxx:"Port"/Images/. However as expected it returns an error. (Cannot find or open file).

How would a go about achieving this. I was trying to search around for webspeed but it seem a bit confusing a this moment. 

-Mathieu- 

Verified Answer
  • Sounds like what you want isn't a copy but an HTTP Post.  There is a built-in HTTP client you can use, which should make this fairly simple.  You're not looking for webspeed.  Webspeed is server technology, but it sounds like you want client side implementation.

    Maybe start here:

    documentation.progress.com/.../index.html

All Replies
  • Sounds like what you want isn't a copy but an HTTP Post.  There is a built-in HTTP client you can use, which should make this fairly simple.  You're not looking for webspeed.  Webspeed is server technology, but it sounds like you want client side implementation.

    Maybe start here:

    documentation.progress.com/.../index.html

  • A big thanks for the help and fast reply.

    This seems to be exactly it . im having an issue while adding the library to propath.

    i have added

    %DLC%\gui\netlib\OpenEdge.Net.pl

    and

    %DLC%\tty\netlib\OpenEdge.Net.pl

    by going in Appbuilder and pro tools then propath button. they where added succelfully but when i use

    USING OpenEdge.Net.URI. i cant a "cannot find class or interface" message. Sorry again for the questions but is there something im missing.

    again thanks for the help