Developer Studio - Remote Server Progress Application Servers for OpenEdge not listed - Forum - OpenEdge Development - Progress Community

Developer Studio - Remote Server Progress Application Servers for OpenEdge not listed

 Forum

Developer Studio - Remote Server Progress Application Servers for OpenEdge not listed

This question is answered

I've been fighting on and off for a while with the 'Servers' under Developer Studio.  Up until now I have been playing with the 'Server' manager against my local Explorer environment, and I am able to see PASOE instances, and I create OpenEdge Projects that link to local PASOE instances.

I would like to start doing the same thing against our group development server PASOE instances.  I've got into Window->Preferences->Progress OpenEdge->Server->OpenEdge Explorer and added a new connection pointing to the remote development server.  Clicking 'Create Servers & Finish' I see the classic appservers and webspeed brokers on the remote server show up in the 'Servers' and 'Progress OpenEdge Servers Monitor' views, but there are no entries listed under Progress Application Servers for OpenEdge.  We do have a number of PASOE instance, with the oemanager stuff installed.

So, what am I missing, or what do I have misconfigured?

Verified Answer
  • Hi,
     
    PDS OE shows only development server instances in servers view and from the pose I can see that, you are also trying to add development servers to the servers view.
    If Create Servers & Finish not creating PAS development servers from remote OpenEdge Explorer configuration, then please try to following steps to add the server:
    1. Go to Servers view and then right click on servers view and select New > Server
    2. Select “Progress Application Server for OpenEdge” entry in New Server wizard and click Next
    3. Select the Explorer connection from which you want to create a server and then “refresh” icon adjacent to “Progress Application Server for OpenEdge”
    4. This will list all the available server instances, select the one you want and click Finish.
     
    If you see any errors after step3, please post it here. So, that we can take a look and see what’s the issue is.
     
    Hope this helps,
    Sanjeev
     
All Replies
  • Hi,
     
    PDS OE shows only development server instances in servers view and from the pose I can see that, you are also trying to add development servers to the servers view.
    If Create Servers & Finish not creating PAS development servers from remote OpenEdge Explorer configuration, then please try to following steps to add the server:
    1. Go to Servers view and then right click on servers view and select New > Server
    2. Select “Progress Application Server for OpenEdge” entry in New Server wizard and click Next
    3. Select the Explorer connection from which you want to create a server and then “refresh” icon adjacent to “Progress Application Server for OpenEdge”
    4. This will list all the available server instances, select the one you want and click Finish.
     
    If you see any errors after step3, please post it here. So, that we can take a look and see what’s the issue is.
     
    Hope this helps,
    Sanjeev
     
  • Sanjeev,

    Thanks for the response. 

    When I use the 'New Server' wizard I get the following a message indicating that Progress Application Server for OpenEdge does not support 'remote hosts' whenever I specify anything but 'localhost' in the 'Server's host name' field.  After trusting 'localhost' would get me to a better place, I saw that the next screen has a select of 'OpenEdge Explorer connection' did indeed show me the services available on the remote server (providing a connect was setup).

    While this works, to me it is counter-intuitive.  For non-PAS servers entering the remote hosts name in the 'Server's host name' field works as expected, and as the documentation for 'Creating a server' suggests it would.

    Thank you for the help.

    Brian