OpenEdge 10.2b - Consuming Web Services - Forum - OpenEdge Development - Progress Community

OpenEdge 10.2b - Consuming Web Services

 Forum

OpenEdge 10.2b - Consuming Web Services

This question is not answered

Hi all,

I have  OpenEdge 10.2b and have error in the consumption of the SOAP webservice.

Error message: 9318

Error message: 9407

Error loading WSDL document  https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl :

Fatal Error: connect operation failed (WinSock reported error=0)

  location: https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl (11748)

Any help would be appreciated.

Many thanks.

All Replies
  • Hi Liliana,
     
    You need to get the required cetificates from the creator of that web service then import them into the  <InstallDir>\certs directory.
     
    Run Proenv to get a command shell, cd to the certs directory then run the certutil -import <CertFileName> command for each certificate they give you.
     
    Brian Maher
    Principal Engineer, Technical Support
    Progress
    Progress
    14 Oak Park | Bedford, MA 01730 | USA
    phone
    +1 781 280 3075
     
     
    Twitter
    Facebook
    LinkedIn
    Google+
     
     
    ProgressNext2018_Email_Signature
     

  • Hi Brian,

    Thanks for answering. I tried what you explained but it works  when I run the

    bprowsdldoc -nohostverify   http://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdlwith http.

    I get the same errors when I tried with https and we need https:

    Error message: 9318

    Error message: 9407

    Error loading WSDL document  https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl :Fatal Error: connect operation failed (WinSock reported error=0) location: https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl (11748)

  • Hi Brian,

    Thanks for answering. I tried what you explained but it works  when I run the

    bprowsdldoc -nohostverify   http://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl  with http.

    I get the same errors when I tried with https and we need https:

    Error message: 9318

    Error message: 9407

    Error loading WSDL document  https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl :Fatal Error: connect operation failed (WinSock reported error=0) location: https://....../SoapApi/web/ServiceUpdatecustomer.svc?wsdl (11748)





    Från: Brian K. Maher <bounce-maher@community.progress.com>
    Skickat: den 4 maj 2018 16:20
    Till: TU.OE.Development@community.progress.com
    Ämne: RE: [Technical Users - OE Development] OpenEdge 10.2b - Consuming Web Services
     
    Update from Progress Community
    community.progress.com
    Know More By Logging In. Log In. Forgot Password

    Brian K. Maher

    Hi Liliana,
     
    You need to get the required cetificates from the creator of that web service then import them into the  <InstallDir>\certs directory.
     
    Run Proenv to get a command shell, cd to the certs directory then run the certutil -import <CertFileName> command for each certificate they give you.
     
    Brian Maher
    Principal Engineer, Technical Support
    Progress
    14 Oak Park | Bedford, MA 01730 | USA
    phone
    +1 781 280 3075
     
     
     
     
     

    View online

     

    You received this notification because you subscribed to the forum.  To unsubscribe from only this thread, go here.

    Flag this post as spam/abuse.