OpenEdge.Net.pl 10.2.B - Forum - OpenEdge Development - Progress Community
 Forum

OpenEdge.Net.pl 10.2.B

This question is not answered

I am using OpenEdge 10.2.B but would like use the OpenEdge.Net.pl library which was introduced in 11.5.1. Is this in any way possible?

I am currently getting a error (Invalid version, 1100 (expected 1005) in object file (2888)) when compiling as the pl file I've added to the propath is expecting me to be running version 11 of progress.

All Replies
  • It is not possible to run the r-code from 11.x in 10.2b – you will see errors similar to what you’re seeing; you should be working from source in that case. You’d also need the OpenEdge.Core.pl library and source.
     
    However, there are also certain language and other elements introduced in 11+ that will cause the 11+ code to not compile – JsonObject support was only added in 11.0 .