Problem with new icons - Forum - OpenEdge Development - Progress Community
 Forum

Problem with new icons

This question is not answered

11.7

I bought some icons from https://www.iconex.com/, but using them out of the box seems not working  for me. I am not sure what I do wrong. It gives me the following error:

unable to find image file for BUTTON save_tbeiSession (2289)

DEFINE BUTTON save_tbeiProject
IMAGE-UP FILE "ico\floppy_disk_ok.ico":U
LABEL "Save"
SIZE 7.8 BY 1.95 TOOLTIP "Save (CTRL-S)".

it has size 48x48 with 32 bit depth.... 

it is within the propath, and should be found....

If I do a search("ico\floppy_disk_ok.ico") I get .\img\ico\floppy_disk_ok.ico, so it is found. I have also tried to change the propath.  It is shown in the designer.

All Replies
  • Are you using 32-bit or 64-bit 11.7?

  • 32bit, I am trying to get it to work with a webclient as well….failing on both dev and webclient….
     
  • Hmmm. I tried to make a window with one of the buttons I can’t get to work, and that worked swell…. Strange…
     
  • I tried it with the icons you provided and it works for me.

    Does it work if you hard code the full path of the icon?

    Does it work if you use the LOAD-IMAGE method?  save_tbeiProject:LOAD-IMAGE("ico\floppy_disk_ok.ico").

  • Sorry, it seems to be a method that does something strange for me here. I will have to dig deeper into this…. If I added an extra button with same icon, I got it to work…. So it has to do with the load of image.. I need to dig a bit … thanks !!
     
    //Geir Otto
     
  • Those icons work well for me.

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • They do…. I found an error in a toolbox I use… my mistake…
     
    Thanks ….
     
    //Geir Otto