editor corruption - Forum - OpenEdge Development - Progress Community
 Forum

editor corruption

  • Using 10.1B and OEA, I often get an issue where the editor "suddenly" (god, I sound like a user) stops working - anything you type (e.g. FOR EACH) does not apear. Pressing delete or backspace produces a java exception. If you save the file and reload, then the text that you tried to enter is backwards (HCAE ROF).

    Anyone else seen anything like this ?

    Julian

  • Hi Julian,

    Please call tech support so that this issue can be dealt with properly.

  • I logged a bug like this ages ago but to do with CTRL-C and CTRL-V causing it and then typing FOR would print ROF (backwards). The only problem is it did it on my system but no one else could replicate it

  • I still get it - normally when I do a cut / copy / paste. Hmm. may look into that - thanks for the info

  • Yep - its always do do with cut/copy/paste

  • Clearly a punishment for being unoriginal!

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • heh.

  • I now get this on a regular (and almost reproducible) basis. It always involves a cut/copy/paste, and seems to happen when the code you are editing does not compile properly.

    If you close the file, and reopen it, you can edit for another little while until the problem reoccurs.

    Once the file compiles ok, there is no problem

  • ok, a further update. This corruption thingy was driving me mad today, and my little trick above had no effect.

    In desperation I updated to Java2 (jre 1.6), and removed the -vm from the OEA startup script (forcing it to use the system default jre) and since then I have had zero problems .... perhaps this may help someone further down the line.

  • I'm having the same problem. I already had 1.6 installed on my box so I removed the -vm "C:\dlc\101b\jre\bin\javaw.exe" reference from my startup, but the issue came back after a few minutes. I'm assuming it didn't do anything and I was just extra careful because I hoped it was fixed. And I was just getting more productive in the new environment then I was in the old one.

    I logged it with tech support, so maybe if enough people encounter it Progress will find the problem. I might try researching some of the Eclipse message boards too.

  • Thanks god I'm not the only "user" here

    Unfortunately, I am still getting the error, but I am starting to learn to live with it. Arrrgghh.

  • oh man. Just installed 10.1B SP1 and it's gotten a whole heap worse. It's impossible to type without getting the exceptions. Dammit.

  • Julian,

    Are you using a multi-core CPU?

  • I think so ... pentium D 3.2GHz .. shows 2 cpus in task manager

    this has been driving me absolutely mad today

  • I'm using two hyperthreaded processors (total of 4 in TM). Progress told me they are just starting their research on the subject. I've given them the link to this thread.

    Don.