Connection profile Progress - Forum - OpenEdge Development - Progress Community
 Forum

Connection profile Progress

  • I'm trying to create a connection profile to Progress database. If the host is my PC (localhost) it's ok but not on the server.

    I have this error message "OE Broker fails to start SQL server".

    The database and the broker are running.

    Connection profile Progress.JPG

  • HI Chris,

    Make sure that your database server can handle SQL connections.  I assume that since your database name in the picture is not pointing to localhost, that you are using a database server that might be shared between users.  Talk to the database admin and ask them to ensure that the SQL database server engine is installed/enabled.

  • Hi Matthew,

    yes, the SQL database server engine is installed and the database server is shared between 10 users. Do I have to configured the MSS Dataserver (broker) or anything like that?

    It's a Progress Database and it's started. One of my projects is connected to it.

  • Have you created a ODBC entry for it?  Something like this http://www.oehive.org/node/1025

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • DB Nav does not require ODBC data sources.  It uses the connection information on the JDBC driver URL to directly connect to the database using host and port.

    Check the database .lg file for any error messages.

  • The MS Dataserver is for for working with Microsoft SQL server.  If you are using an OpenEdge database the only thing you need is the JDBC drivers which appear to be installed properly.  What version of database are you trying to connect to?  Check the database .lg file for the database server to find out why the sql server process is not starting.

  • The JDBC Drivers are  installed properly. It's a database Progress 10. I checked the .lg file for my database. There are 2 messages :

    1. [2009/05/13@09:17:39.273+0200] P-15960      T-10584 I SRV     2: (742)   Connecting 22, identifiant CMabileau on cmabilleau-w-xp (my workstation).

    2. [2009/05/13@09:18:11.758+0200] P-6736       T-15408 I BROKER  0: (8840)  Unable to start the SQL server.

  • Potentially, your broker has run out of resources meaning the DB server startup parameters need to be adjusted (-Mn in particular).

  • The value of the paramter -Mn is 4. I think it's good.

  • christophe.mabileau wrote:

    The value of the paramter -Mn is 4. I think it's good.

    Which means you can have 4 auto servers.. What is -Mi? If it is 1, then the first 4 people to login to the DB will each get an auto server and the broker will be unable to spawn any new ones, resulting in the message you were getting when attempting to connect via Architect.

  • The value of the -Mi parameter is 2. I'm the only one to connect to the database. I put 2 files as attachments. I'm french so there are in french.

  • Okay. Potentially its a bug. You will need to upgrade to SP3 before contacting TS, though.

    Your log says:

    Progress OpenEdge Release 10.1B build 1216 sur WINNT

    Where post SP3 install it will be:

    Progress OpenEdge Release 10.1B build 1372 SP03 on WINNT

  • Do you have your database configured using Progress Explorer?

    Can you put the print screens of your db-configuration in a post? Or the conmgr.properties file (/properties folder).

    What you can do is start a secondary broker on the database using command line (use ProEnv in Program Folder):

        proserve -m3 -ServerType SQL -s 12000

    and use this port (12000) in your connection profile.

    If you get errors using the proserve command, please post them.

  • Here attached the conmgr.properties file of the server.

    I tried to start a secondary broker using command line wihout error and use the port 12000 in my connection profile but it doesn't work.

    I see on the server that OpenEdge Architect is not installed !!!! It could be an explanation?

  • Sorry my mistake,

    I typed -s, it should be -S 12000, connection parameters are case sensitive.

    Can you please add your db log file should it not work?

    Is your db on a different machine? No need for OEA to be installed there, but you need Workgroup or Enterprise license to allow remote client connections.

    Thx