Architect intermittently hanging when “launching delegate” - Forum - OpenEdge Development - Progress Community

Architect intermittently hanging when “launching delegate”

 Forum

Architect intermittently hanging when “launching delegate”

  • Just wondered if anyone has had this issue before.

    I have two machines, both running Architect, one is 10.2a (windows 7) the other 10.2b (windows vista). The running configurations are identical running the same set of programs. However, the 10.2b machine intermittently hangs when running a program (see screenprint), the 10.1c machine works perfect everytime.

    I've googled the error but there is little help available.

    Help

             

    screenprint.jpg

  • I have found this..

    http://markmail.org/message/vrfiv3d6zzt4no5y#query:+page:1+mid:v7ahleye2tlf645z+state:results

    It seems related to the Information dialog box which displays when you run a program (this seems to be an addition in 10.2b).

    With the dialog box displayed I cannot access the run program and in affect the whole application is frozen & I have to remove the process from task manager. I have left the dialog box "running" for over 20minutes and nothing happens, similarly, if you try and cancel the operation the application freezes. This is not just happening on one of our programs but many and like I said previously it is intermittent.

    In 10.2a the dialog box is not displayed (but viewable in the progress view) therefore I can access the run program which executes in seconds. I've attached further screen shots.

    Any help would be much appreciated.

    Dez

  • Derek, how is your launch config setup?  Are you using the same session as the AVM or are you using a new AVM?  Did you check for a dialog in the background?

  • There is no message in the background I have double checked.


    I have attached screenshots of the configuration, it is the same setup to that of a 10.2a machine in which we are having no problems with whatsoever.


    On some java forums other users have had problems with the information dialog hanging. As this seems to be an addition in 10.2b, is there a way to turn this off?


    We are classing this as a fairly serious issue as it prevents us from running many programs in our current workspace.


    Thanks, Dez

  • What happens if you use the 'Start new OpenEdge AM' option in the Main section?

  • If I select "start new avm session" it seems that it is not invoking our shared variables - I get the message "shared variable xxx has not yet been created".


    These are stored in our _idestartup file so I assume its not running that.


    Dez

  • The "run with project avm" is there "just in case".  Using this style of launch config prevents you from running the debugger using that launch config as well as blocking the AVM associated with the project.  I encourage you to not use if it possible for running your code.  It is subject to being blocked by any dialog running in the AVM such as file system save dialogs from the appbuilder or any message box.

    It WILL hang indefinitely if there is a message dialog open in the AVM associated with the project.  There is an option on the launch config dialog (last tab) to "run in background".  Try changing this to see if that helps with the display of the Eclipse wait dialog.

    _idestartup.p only runs for the avm associated with projects.  When running your application you should be using your own startup/bootstrap program.  _idstartup.p is there to setup stuff specific to your development environment such as subscribing to IDE events or starting your own tooling.  You shouldn't rely on it being a part of your application otherwise you run into "shared variable not definited" messages.

    This doesn't mean you can't use the "run with project avm", but you will run into situations that don't work so well due to the single-threaded nature of the AVM.  This was one of the main reasons for adding launch configs.  Older versions of OEA only allowed you to use the project AVM instead of a separate AVM.

  • Hey Matt,


    Selecting "launch in background" worked just great. Thanks again for your help.


    Dez