deployREST error message - Forum - OpenEdge Development - Progress Community
 Forum

deployREST error message

This question is not answered

Hi --

I'm running deployREST in ProEnv and getting a vague error message:

"\Progress\OpenedgeWrk\oepas1 was unexpected at this time"

Can anyone help?

This is part of the wbt class "Providing OpenEdge Applications as Rest Web Applications (1000-053)"

I get a kick out of the "at this time" part of the message. I obviously flipped my middle finger at the screen and shouted "Feel free to unexpect my path whenever it's convenient to you!"

TIA - Jim

All Replies
  • Hi Jim,

    May I know how your deployREST complete command looks like to understand why this issue occur

    Regards,

    Irfan

  • Hi Irfan --

    Here is more detail:

    Click: ProEnv

    Proevn replies" Inserting C:\PROGRA~2\Progress\OpenEdge\bin to beginning of path and current directory is C:\Program Files (x86)\Progress\OpendgeWrk"

    Type: cd oepas1\webapps

    Type: C:\"Program Files (x86)"\Progress\OpenEdgeWrk\oepas1\bin\deployREST CustomerOrderApp.zip root

    Proenv replies "\Progress\OpenEdgeWrk\oepas1 was unexpected at this time

    I tried a few variations, like "..\bin\deployREST" instead of full path and get the same result.   :-(

    Could it have something to do with the <spaces> in "Program Files (x86)" being in the path??

    Thanks again -- Jim

  • My deployRest is in this folder:

    C:\OpenEdge\WRK\oepas1\bin\

    If you are inside the folder (cd C:\OpenEdge\WRK\oepas1\bin\) then you just need to run this line:

    deployREST.bat <YOUR_REST_SERVICE>.zip ROOT.

  • Hi Jim,

    I think that might be a problem. To confirm, can you please do the same on a command prompt by setting DLC and WRKDIR

    Regards,

    Irfan

  • Hi Jim,

    I see that you are trying to deploy a zip file to your PASOE Instance, if that is the case then the command would look as below

    tcman deploySvc <incremental-zip-name> <existing-web-application-name>

    deployREST.bat is used to deploy .paar artefacts

    Regards,

    Irfan

  • You are supposed to pass .paar file to deployREST not .zip file. Try like this.
     
     
    Thanks,
    Satya
     
  • When I did this, I also exporteded as a .zip, and deployRest.bat worked just fine.

  • Not sure what you are requesting. Can you give me a few step-by-step?

    Or should I just re-install Progress in C:\Progress\Openedge ??

  • Can you please tryout these steps

    Open command prompt

         Start -> Command Prompt

    set DLC and WRKDIR

           set DLC=C:\Progress\OpenEdge

           set WRKDIR=C:\OpenEdge\WRK

    Verify that both these values are set correctly

            echo %DLC%

            echo %WRKDIR%

    Now goto your instance bin location

            cd $WRKDIR/oepas1/bin

    If you are deploying a paar file, run the below command

              deployREST.bat <paar file with location>   ROOT

    If you are deploying a zip file, run the following

              tcman.bat deploysvc <zip file with location>  ROOT

    Regards,

    Irfan

  • Hi Irfan --

    I tried that a few different ways. I assume you meant "cd %WRKDIR%\oepas1\bin .

    I had to use MY Progress path instead of C:\Progress\OpenEdge.

    I am trying to deply a .zip, so I used tcman instead of deployREST.

    The tcman churned for a while and then choked with screenfuls of errors. It starts with:

    cp: access to the path C:\Program Files (x86)\Progress\OpenEdgeWRK\oepas1\temp\catalina-pid.tmp is denied.

    I'll try to send you a screenshot.

    I tried doing ProEnv via "Run as Administrator" (in case it was some weird permissions thing), and invoked the same tcman from there, but that resulted in a response of "deploysvc bad command line option".

  • This course is tailored toward OpenEdge 11.4 and the classic REST Adapter. The paar file created with this course can be deployed on PASOE as is. I have less confidence that the zip file generated via this course, but I would have to dig into the course to confirm that. We have created a new OpenEdge Project Type (ABL Web App) in 11.6 that is meant for PASOE. Until the education courses are updated for PASOE, you could try replication the course, but starting with this project type.

    Dave