Installing AutoEdge|TheFactory on 11.6 Classroom Edition - Forum - OpenEdge Development - Progress Community

Installing AutoEdge|TheFactory on 11.6 Classroom Edition

 Forum

Installing AutoEdge|TheFactory on 11.6 Classroom Edition

This question has suggested answer(s)

Anyone successfully installed AutoEdge|TheFactory on 11.6 Classroom Edition?

I downloaded the latest release, ran the installer which appeared to complete OK and I now have some relevant icons in my Start menu.

The Getting Started web page says 'check the AppServer and database setups in OpenEdge Explorer/Management, and start the DB ("dbAutoEdgeTheFactory") and AppServer ("asAutoEdgeTheFactory")'.  These aren't showing in Progress Explorer and aren't in the .properties files.

So what now?

All Replies
  • Grant,
     
    There are a couple of things that spring to mind – the first being that the restore of the db failed.
     
    You can quite easily add the DB's to Explorer yourself if it's there.
     
    I'll try running the install here and see whether it works with vanilla 11.6 (although it should Just Work).
     
  • Hello Peter

    Thanks for the swift reply.  The DB restore worked fine so maybe just a case of adding the DB manually.  Does the installer create an installation log file?

    Please let me know how you get on with your 11.6 test.

    Cheers.

  • The installer uses InnoSetup, and there are some switches you can use to control the verbosity/logging: www.jrsoftware.org/.../topic_setupcmdline.htm

    I did a quick install and the DB and appservers are written into my conmgrp. and  ubroker.properties files, using the 64-bit version on Windows 7.

  • Hello Peter

    The install process created aetf.conmgr.properties and aetf.ubroker.properties files so I cut'n'pasted their contents into the actual .properties.  The database now starts OK but appserver fails.  Unfortunately I'm not familiar with AppServer so will need some assistance.  The log file is as following:

    [15/11/18@08:18:50.222+0000] P-008960 T-007104 1 AS -- Logging level set to = 2

    [15/11/18@08:18:50.222+0000] P-008960 T-007104 1 AS -- Log entry types activated: ASPlumbing,DB.Connects

    [15/11/18@08:18:50.222+0000] P-008960 T-007104 2 AS AS Starting application server for asAutoEdgeTheFactory. (5560)

    [15/11/18@08:18:50.259+0000] P-008960 T-007104 2 AS AS Application Server Startup. (5473)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:59) *** Progress.Lang.AppError

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:60) AutoEdge.Factory.Server.Common.CommonInfrastructure.TenantManager is not a valid type

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) ArgumentIsValidType OpenEdge.Lang.Assert at line 197  (.\referencecomponents\support\bin\OpenEdge\Lang\Assert.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) To OpenEdge.Core.InjectABL.Binding.BindingBuilder at line 83  (.\referencecomponents\injectabl\bin\OpenEdge\Core\InjectABL\Binding\BindingBuilder.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) Load AutoEdge.Factory.Server.InjectABL.CommonModule at line 48  (.\autoedgethefactory\server\bin\AutoEdge\Factory\Server\InjectABL\CommonModule.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) OnLoad OpenEdge.Core.InjectABL.Binding.Modules.InjectionModule at line 70  (.\autoedgethefactory\server\bin\OpenEdge\Core\InjectABL\Binding\Modules\InjectionModule.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) Load OpenEdge.Core.InjectABL.KernelBase at line 162  (.\referencecomponents\commoninfrastructure\shared\bin\OpenEdge\Core\InjectABL\KernelBase.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) C:\Program Files (x86)\OpenEdgeAE\AutoEdge\Factory\autoedgethefactory\server\bin\load_injectabl_modules.r at line 36  (C:\Program Files (x86)\OpenEdgeAE\AutoEdge\Factory\autoedgethefactory\server\bin\load_injectabl_modules.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) Load OpenEdge.Core.InjectABL.KernelBase at line 225  (.\referencecomponents\commoninfrastructure\shared\bin\OpenEdge\Core\InjectABL\KernelBase.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) Load OpenEdge.Core.InjectABL.KernelBase at line 252  (.\referencecomponents\commoninfrastructure\shared\bin\OpenEdge\Core\InjectABL\KernelBase.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) OpenEdge/CommonInfrastructure/Common/start_session.p at line 101  (.\referencecomponents\commoninfrastructure\shared\bin\OpenEdge\CommonInfrastructure\Common\start_session.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- (Procedure: 'OpenEdge/CommonInfrastructure/Server/as_startup.p' Line:61) OpenEdge/CommonInfrastructure/Server/as_startup.p at line 41  (.\referencecomponents\commoninfrastructure\server\bin\OpenEdge\CommonInfrastructure\Server\as_startup.r)

    [15/11/18@08:18:50.856+0000] P-008960 T-007104 1 AS -- OpenEdge/CommonInfrastructure/Server/as_startup.p  startup procedure ended with an ERROR condition. (8025)

    [15/11/18@08:18:50.857+0000] P-008960 T-007104 2 AS AS Application Server Shutdown. (5476)

  • Hi Grant,

    The problem could be with  load_injectabl_modules.r outdate compiled version. Please check load_injectabl_modules.r compile date at location <install_dir>/autoedgethefactory/server/bin. May be because of this Appserver did not started. Delete this load_injectabl_modules.r file and re-compile. Then start Appserver.

    Please check the following link, which will helps to solve this AutoEdge App-server issue.

    knowledgebase.progress.com/.../Unable-to-start-the-AutoEdge-appserver

    Regards,

    Satyam

  • Hi Satyam

    Thanks, I followed the KB instructions and the AppServer is now running :-)

    As an aside, compile_loadinjectabl.p had routinelevel.i in it but this is nowhere in the AutoEdge install.  However I commented it out and the program then worked.

  • A little further...

    Finished setup as per instructions (excluding the Savvion part).  Changed Dealer Reviewer GUI from prowin32.exe to prowin.exe and ran it but got the attached errors.  Have I missed something in the install process or does the Classroom Edition lack the required Infragistics .NET controls?

  • Grant,
     
    This may be caused by the older Infragistics assemblies not being on your machine.  Try using the 'Update Assembly References' option that you will find under the OpenEdge -> Migration menu option to update the assemblies to the ones you have installed.
     
    Brian

  • Hello Brian

    Just tried that but no success.  If it helps here's a dump of the screen that came up:

  • Grant,
     
    What are the options in the "Choose new version" combo box?
     
    Brian

  • Grant,

    I am checking but I don't think the classroom edition installs the Infragistics controls.  If I am correct you will not be able to use AutoEdge unless you can (perhaps) download an eval/trial edition of the controls directly from Infragistics.

    Brian

  • There nothing in the combo box at all!

    I suspect you're right there, Brian.  I come from a V9 world so wouldn't know how to prove this for certain.

  • Grant,

    Hmm .. I just got a response that says we do install an evaluation copy of Infragistics with the Classroom edition so now I am even more confused why you don't see anything in the combo box.

    I'm going to install this here and play around with it.  I'll let you know what I find out.

    Brian

  • Grant,

    The Infragistics controls are installed, however, they appear not to be installed into the GAC.  Use the 'Update Assembly References' option again and for each Infragistics control use the browse button and navigate to C:\Progress\OpenEdge\bin\Infragistics\winforms and select the replacement.

    Brian

  • Many thhanks for looking into this Brian.

    I've updated the assemblies as per your instructions, however the following message came up for every one I selected (with different .dll name for each) and AutoEdge is still trying to use the v13 versions: