Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen) - Forum - OpenEdge Development - Progress Community

Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen)

 Forum

Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen)

This question is not answered

Good morning,

We are developing a device Aplication in VS2008 to DataColection, and we are using webservice progress, which generate the sources * .re with proxygen we generate the WSDL to import the WSA with Tomcat and is working OK.
The problem starts when we connect the WebService via VS2008 or via Device Aplication the Collector, because does not present all the methods correctly after being imported into WebReference.
We did a test with aplication console and it worked perfectly.

Can anyone help us?

Thanks.

All Replies
  • If I understand your problem correctly, you are saying that some third party application (VS2008) is not detecting all methods available in the WSDL. Is this correct? If so, have you tried other tools (e.g. SOAPUI) to see if they have similar issues? Can you determine anything in common amongst the ones that are failing?

  • Hello Garry,

    Thanks for the feedback first.

    In SOAPUI it works OK calling the methods of the WSDL Progress.

    In VS2008 when created "Device Aplication" make the object instance and call the method CONNECT_ and displays the error 10963 and 10894 in the log WSA.

    Within the VS2008 own when creating a "Aplication Console" and made the same process to add the WSDL to call works like SOAPUI ... I think the problem is in the "Device Aplication", but I can not understand why does not work properly .. need help to solve it.

    Thanks.

  • You'd probably want to compare the requests made by VS2008 and SOAPUI, to see what is different. Without further information, I would guess it is an incompatibility between the WSDL and VS2008. I don't know much about web services, so If you get no further help here, I would suggest logging a call with Tech Support for assistance.

  • This kb sounds a lot like your issue.

    knowledgebase.progress.com/.../P14653

  • I read that KBASE, the WSA has always been active with this option, but works with console aplication or SOAPUI.

    Please I need help to resolve this problem or orientation.

  • Garry,

    How do I open call to the help desk support in this situation?

    Honestly, I've read everything that exists on the internet about it and could not figure out what can be.

    thanks

  •  
    VS2008 is very old.  Have you tried with a newer version?
     
     

  •  
    www.progress.com/support .. last two large green icons on the right
     
    From: jftalmeida [mailto:bounce-jftalmeida@community.progress.com]
    Sent: Wednesday, July 08, 2015 7:15 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: [Technical Users - OE Development] Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen)
     
    Reply by jftalmeida

    Garry,

    How do I open call to the help desk support in this situation?

    Honestly, I've read everything that exists on the internet about it and could not figure out what can be.

    thanks

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi Brian,

    In the new VS2013 version, there is more Device Aplication.

  •  
    Did you mean no more device application?
     
    How about trying, VS2010 or VS 2012?
     
     

  • Yes... but don't have too.

    Progress support is a waste.

    First time we are in need of more specific support and no one can help us.

    It's complicated.

  • >> Progress support is a waste.

    I work in support and we are most definitely not a waste.

    >> First time we are in need of more specific support and no one can help us.

    It doesn't sound like you actually opened a case with support (note: this site is not technical support)  If you did open a support case please provide the case number.

    >> It's complicated.

    Complicated to open a support case?  The only complication to that is if you have no maintenance contract with Progress (which all active developers should have).

     

  • jftalmeida

    Progress support is a waste.

    First time we are in need of more specific support and no one can help us.

    It's complicated.

    Having worked with tech support for years, I've found them to be the most helpful, quickest way to get from a thorny problem to a solution - or an explanation of what's going on.

    So I have to wonder if you've even talked to them, and if so - who? 

    If you've got active maintenance, you get tech support - and the fastest way to get your question answered is to call them. 

    You'll find their contact information here:

    https://www.progress.com/support

  • Dear,

    We are indirect customers of progress, but we have the licenses directed to our company, in this case the progress does not open call. What surprises us is that the license document itself there REGISTERED TO: 61104365 and still can not open the call.

    How to solve the problem we are seeking documentation, read, understand, test various ways to work, but nothing works, so the first time we are trying to help here and unfortunately not the satisfaction.

  •  
    If you are an end user of a VAR/reseller then you are required to obtain your support from the company whom you purchased your product through.
     
    However, that company can always open a support case with us ON YOUR BEHALF if they cannot solve the problem.  All we require is that that company must stay engaged in the support process (i.e. they cannot just open a case with us and say "call person <x> and number <y> and leave me out of it".
     
    I recommend that you go back to whomever you normally obtain support from, open a support case with them and if they cannot help you then you need to request/demand that they contact Progress Support on your behalf and open a case.