.NET error in .w file ... - Forum - OpenEdge Development - Progress Community
 Forum

.NET error in .w file ...

  • I have a UIB window (called ViewScannedImages.w) that has a browser, an editor box, three buttons and an Adobe acrobat activeX component.

    Whenever I press "Tab" when I first go into this window, I get a

    System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

    The debug trace gives the following

    --> startp.r (startp.r) at line 32

        C:\data\testing\runtime\Darwin\startup.p (C:\data\testing\runtime\Darwin\startup.r) at line 3

    .NET StackTrace:

    -->   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)

       at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)

       at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)

       at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)

       at System.Windows.Forms.Application.Run()

    Line 32 of startp.p is

    WAIT-FOR Application:RUN().

    Why the .net error when I'm in a .w ?

  • You are using a .NET WAIT-FOR, Application:RUN() stands for System.Windows.Forms.Application:Run() as far as I know.

    When I switched to the .NET WAIT-FOR statement, all my access violation exceptions (Exception code: C0000005 ACCESS_VIOLATION) that previously caused my prowin32.exe to crash and generate a protrace and a procore file now ended up generating the .NET exception.   I hoped that I could CATCH those .NET exceptions, but unfortunately I couldn't: the application still crashed, but without the protrace and procore file.

  • Hi Julian,

    Did yuou resolve your problem.

    I've also an activeX in my UIB window. This window is embedded in a .NET Form.

    When I close and reopen this form quickly, I have your message.

    When I repeat these actions slowly, it's better.

    It seems to be a problem with the Progress GC but I'm not sure.

    Maybe I don't release activeX object correctly?