Installing 32 bit OE10.2A on 64 bit windows 7 - Forum - OpenEdge Development - Progress Community

Installing 32 bit OE10.2A on 64 bit windows 7

 Forum

Installing 32 bit OE10.2A on 64 bit windows 7

This question is not answered

Hi,


According to the knowlegde base this should be possible but I have run into difficulties. After downloading and installing 10.2A from the Progress download center (alog with the licenses) I don't seem to be able to create a new project in Eclipse. I get the following error:

"The selected wizard could not be started.
  Plug-in com.openedge.pdt.text was unable to load class com.openedge.pdt.text.wizards.OENewProjectWizard.
  An error occurred while automatically activating bundle com.openedge.pdt.text (25)."

I installed OpenEdge into a folder on my C drive called dlc10 and have set the environment variable DLC to C:\dlc10. Other apsects of the installation such as the appbuilder work OK, it's just Eclipse.

Has anyone else experienced this?

Thanks,

Mark.

P.S. When trying to patch my install up to 02 I get the following error:

---------------------------
Exiting Install
---------------------------
OpenEdge r10.2A installation corrupted:

   "DLC" registry key not found.

Click OK to exit.
---------------------------
OK   
---------------------------

So, it looks like something has not installed correctly.

All Replies
  • Hi,

    Do you have launch your install with Administrator profil (right clic > Execute as Administrator) ?

    Nicolas

  • Hi,

    I tried this but it made no difference.

    Thanks,

    Mark.

  • Chances are you're one of the many unfortunate victims of a nasty installer bug that leaves bad registry keys.

    See knowledgebase.progress.com/.../000012311 for more details, and

  • Thanks, I ran the registry fix on the KB and it allowed me to patch the install to 02 but now I get this error when trying to run Eclipse:

    java.lang.RuntimeException: No application id has been found.

    at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)

    at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:585)

    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)

    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)

    at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

    at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

    This is my start up command:

    C:\dlc10\oeide\eclipse\eclipse.exe -showlocation -vm "C:\dlc10\jre\bin\javaw.exe"

  • Hi Beynon,

    Please try re-installing architect's plugins with following steps.

    1. Open Proenv.

    2. Run following commands.

    <DLC>\oeide\integrateArchitect -uninstall <<DLC>\oeide\eclipse

    <DLC>\oeide\integrateArchitect -install <<DLC>\oeide\eclipse

    Also, KB article knowledgebase.progress.com/.../P154754 might help.

    Hope this helps,

    DivyaTheja

  • Hi,

    Unfortunately, I don't have "integrateArchitect" in my oeide folder, perhaps because I'm installing version 10.2A?

    Mark.