-useOSLocale OpenEdge problem - Forum - OpenEdge Development - Progress Community
 Forum

-useOSLocale OpenEdge problem

  • Good day!

    I just installed new Openedge 10.2B development environment.

    New Run time configuration with the following options (Culture tab page) throws some exception:

    1. Use defaults - UNCHECKED
    2. Use OS Locale - CHECKED
    3. Case Table - Basic
    4. Collation table - Croatian
    5. Date format - dmy
    6. Year offset - 1950
    7. Fractional separator - 44
    8. Decimal separator - 46
    9. Internal code page - 1250
    10. Stream code page - 1250
    11. Other input widgets - empty or unchecked

    Exception details: Attribute abl.i18n.USE_EUROPEAN_FORMAT is not of type boolean.

    Attached files are screenshots.

    Thanks!

  • Exception details: Attribute abl.i18n.USE_EUROPEAN_FORMAT is not of type boolean.

    I'd certainly contact tech support. I tried the settings from your post and don't run into that error.

    11. Other input widgets - empty or unchecked

     

    Where did you find that setting?

  • Sorry, i didn't explain that problem correctly.

    Error is thrown after clicking on Run button.

  • Error is thrown after clicking on Run button.

    That's how I understood it. Didn't throw an error like that on my workspace.

  • It is a bug.  Please contact tech support about this so that it can logged/fixed.  You have the -E parameter specified in the default startup.pf file in your installation directory of OpenEdge and it is imported incorrectly into new launch configurations.

    To work around the issue you have three options,

    1.  Remove the -E parameter from the startup.pf and replace it with the appropriate values for -d, -numsep, and -numdec parameters and then recreate the launch configuration.

    2.  Manually edit the launch configuration to remove the offending parameter.  They are stored as .xml files in /.metadata\.plugins\org.eclipse.debug.core\.launches.  You would need to do this for each launch configuration.

    3.  Turn on "use defaults" on the launch configuration culture tab and manually provide the appropriate startup parameters in either your own .pf file or in the "additional startup parameters" field of the launch configuration.  You would need to do this for each launch configuration.

  • Thanks!