Initilaize Smart Data Browser with no data - Forum - OpenEdge Development - Progress Community

Initilaize Smart Data Browser with no data

 Forum

Initilaize Smart Data Browser with no data

This question is not answered

I am trying to display the data in smart data browser based on the search fields.

But on initialization , it is getting populated with data . I want to initialize it with no data .

Can anybody please help me with this? Is there any property in smart data browser that need to be set.

All Replies
  • On the window you could set the Open query on initialization of on the linked SDO.

    This on the instance  properties.

    After the run super in the initializeObject of the window you can turn it on.

    Regards, Peter Wokke

  • Thanks Peter. It would be great if you could tell me how to turn open query on after super. I am new to OE.

  • When you set the filter on the SDO in a setFilter procedure like this

           /* release the previous set filter */

           DYNAMIC-FUNCTION('setQueryWhere':U IN h_di_cropyear-availability,'':U).

           /* add filter settings */

           DYNAMIC-FUNCTION('addQueryWhere':U IN h_di_cropyear-availability,

                           'cropyear.artnr = ':U + string(m_iArtnr),

                           'cropyear':U,

                           'and':U).

           DYNAMIC-FUNCTION('addQueryWhere':U IN h_di_cropyear-availability,

                           'cropyear.received = false':U,

                           'cropyear':U,

                           'and':U).

           DYNAMIC-FUNCTION('addQueryWhere':U IN h_di_cropyear-availability,

                           'crop.iscuscon = false':U,

                           'crop':U,

                           'and':U).

           /* get data */

           DYNAMIC-FUNCTION('openQuery':U IN h_di_cropyear-availability).

    The filters can be set on if statement that when the user has selected on that field.

    The function openQuery will show the data.

  • sdo_props.JPG

    , in AppBuilder, select "Instance Properties" of SDO and uncheck "Open query on initialization". See the attached screenshot