Agent Sessions disabled on OE Explorer, 12.1 - Forum - OpenEdge Development - Progress Community

Agent Sessions disabled on OE Explorer, 12.1

 Forum

Agent Sessions disabled on OE Explorer, 12.1

This question is answered

I'm running a dev instance of PASOE in version 12.1 on Windows.  When I start my instance - whether through OpenEdge Explorer or through tcman commands, I'm seeing that the Agent Sessions link within the explorer is not enabled:

I have oemanager installed and running within the instance:

proenv>tcman list -u user:pass
OK - Listed applications for virtual host [localhost]
/:running:0:ROOT
/manager:running:1:manager
/Ingrid:running:0:Ingrid
/oemanager:running:0:oemanager

What am I doing wrong here?  Why isn't this tool working?

For what it's worth, oejmx works fine in this environment, and I can view my agents that way, but I feel like I shouldn't have to.

Verified Answer
  • Well, I got it figured out.  My instance's connection configuration screen had an incorrect port in the URL for oemanager.  For some reason, it had 8811 in it, even though my instance's SSL connection is on 8821.  Once I fixed that, it started working.

All Replies
  • Generally these links gets disabled when oemanager is not accessible.

  • That was my thinking too, but tcman reports that oemanager is running on the instance.  I'm not sure why OpenEdge Explorer is not picking up on that.

  • Well, I got it figured out.  My instance's connection configuration screen had an incorrect port in the URL for oemanager.  For some reason, it had 8811 in it, even though my instance's SSL connection is on 8821.  Once I fixed that, it started working.